%global _empty_manifest_terminate_build 0
Name: python-hachoir
Version: 3.2.0
Release: 1
Summary: Package of Hachoir parsers used to open binary files
License: GNU GPL v2
URL: http://hachoir.readthedocs.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b2/bd/7529c99100fc4b688758194ef6ad23028461bb8a6376e6beba8b8ae93be0/hachoir-3.2.0.tar.gz
BuildArch: noarch
Requires: python3-urwid
Requires: python3-darkdetect
Requires: python3-wxPython
%description
*******
Hachoir
*******
.. image:: https://img.shields.io/pypi/v/hachoir.svg
:alt: Latest release on the Python Cheeseshop (PyPI)
:target: https://pypi.python.org/pypi/hachoir
.. image:: https://github.com/vstinner/hachoir/actions/workflows/build.yml/badge.svg
:alt: Build status of hachoir on GitHub Actions
:target: https://github.com/vstinner/hachoir/actions
.. image:: http://unmaintained.tech/badge.svg
:target: http://unmaintained.tech/
:alt: No Maintenance Intended
Hachoir is a Python library to view and edit a binary stream field by field.
In other words, Hachoir allows you to "browse" any binary stream just like you
browse directories and files.
A file is splitted in a tree of fields, where the smallest field is just one
bit. Examples of fields types: integers, strings, bits, padding types, floats,
etc. Hachoir is the French word for a meat grinder (meat mincer), which is used
by butchers to divide meat into long tubes; Hachoir is used by computer
butchers to divide binary files into fields.
* `Hachoir website `_ (source code, bugs)
* `Hachoir on GitHub (Source code, bug tracker) `_
* License: GNU GPL v2
Command line tools using Hachoir parsers:
* hachoir-grep: find a text pattern in a binary file
* hachoir-metadata: get metadata from binary files
* hachoir-strip: modify a file to remove metadata
* hachoir-urwid: display the content of a binary file in text mode
Installation instructions: http://hachoir.readthedocs.io/en/latest/install.html
Hachoir is written for Python 3.6 or newer.
%package -n python3-hachoir
Summary: Package of Hachoir parsers used to open binary files
Provides: python-hachoir
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-hachoir
*******
Hachoir
*******
.. image:: https://img.shields.io/pypi/v/hachoir.svg
:alt: Latest release on the Python Cheeseshop (PyPI)
:target: https://pypi.python.org/pypi/hachoir
.. image:: https://github.com/vstinner/hachoir/actions/workflows/build.yml/badge.svg
:alt: Build status of hachoir on GitHub Actions
:target: https://github.com/vstinner/hachoir/actions
.. image:: http://unmaintained.tech/badge.svg
:target: http://unmaintained.tech/
:alt: No Maintenance Intended
Hachoir is a Python library to view and edit a binary stream field by field.
In other words, Hachoir allows you to "browse" any binary stream just like you
browse directories and files.
A file is splitted in a tree of fields, where the smallest field is just one
bit. Examples of fields types: integers, strings, bits, padding types, floats,
etc. Hachoir is the French word for a meat grinder (meat mincer), which is used
by butchers to divide meat into long tubes; Hachoir is used by computer
butchers to divide binary files into fields.
* `Hachoir website `_ (source code, bugs)
* `Hachoir on GitHub (Source code, bug tracker) `_
* License: GNU GPL v2
Command line tools using Hachoir parsers:
* hachoir-grep: find a text pattern in a binary file
* hachoir-metadata: get metadata from binary files
* hachoir-strip: modify a file to remove metadata
* hachoir-urwid: display the content of a binary file in text mode
Installation instructions: http://hachoir.readthedocs.io/en/latest/install.html
Hachoir is written for Python 3.6 or newer.
%package help
Summary: Development documents and examples for hachoir
Provides: python3-hachoir-doc
%description help
*******
Hachoir
*******
.. image:: https://img.shields.io/pypi/v/hachoir.svg
:alt: Latest release on the Python Cheeseshop (PyPI)
:target: https://pypi.python.org/pypi/hachoir
.. image:: https://github.com/vstinner/hachoir/actions/workflows/build.yml/badge.svg
:alt: Build status of hachoir on GitHub Actions
:target: https://github.com/vstinner/hachoir/actions
.. image:: http://unmaintained.tech/badge.svg
:target: http://unmaintained.tech/
:alt: No Maintenance Intended
Hachoir is a Python library to view and edit a binary stream field by field.
In other words, Hachoir allows you to "browse" any binary stream just like you
browse directories and files.
A file is splitted in a tree of fields, where the smallest field is just one
bit. Examples of fields types: integers, strings, bits, padding types, floats,
etc. Hachoir is the French word for a meat grinder (meat mincer), which is used
by butchers to divide meat into long tubes; Hachoir is used by computer
butchers to divide binary files into fields.
* `Hachoir website `_ (source code, bugs)
* `Hachoir on GitHub (Source code, bug tracker) `_
* License: GNU GPL v2
Command line tools using Hachoir parsers:
* hachoir-grep: find a text pattern in a binary file
* hachoir-metadata: get metadata from binary files
* hachoir-strip: modify a file to remove metadata
* hachoir-urwid: display the content of a binary file in text mode
Installation instructions: http://hachoir.readthedocs.io/en/latest/install.html
Hachoir is written for Python 3.6 or newer.
%prep
%autosetup -n hachoir-3.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-hachoir -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 3.2.0-1
- Package Spec generated