%global _empty_manifest_terminate_build 0
Name: python-pywinrm
Version: 0.4.3
Release: 1
Summary: Python library for Windows Remote Management
License: MIT license
URL: http://github.com/diyan/pywinrm/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7c/ba/78329e124138f8edf40a41b4252baf20cafdbea92ea45d50ec712124e99b/pywinrm-0.4.3.tar.gz
BuildArch: noarch
Requires: python3-xmltodict
Requires: python3-requests
Requires: python3-requests-ntlm
Requires: python3-six
Requires: python3-requests-credssp
Requires: python3-pykerberos
Requires: python3-winkerberos
%description
pywinrm is a Python client for the Windows Remote Management (WinRM)
service. It allows you to invoke commands on target Windows machines
from any machine that can run Python.
|License| |Test workflow| |Coverage| |PyPI|
WinRM allows you to perform various management tasks remotely. These
include, but are not limited to: running batch scripts, powershell
scripts, and fetching WMI variables.
Used by `Ansible `__ for Windows support.
For more information on WinRM, please visit `Microsoft’s WinRM
site `__.
%package -n python3-pywinrm
Summary: Python library for Windows Remote Management
Provides: python-pywinrm
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pywinrm
pywinrm is a Python client for the Windows Remote Management (WinRM)
service. It allows you to invoke commands on target Windows machines
from any machine that can run Python.
|License| |Test workflow| |Coverage| |PyPI|
WinRM allows you to perform various management tasks remotely. These
include, but are not limited to: running batch scripts, powershell
scripts, and fetching WMI variables.
Used by `Ansible `__ for Windows support.
For more information on WinRM, please visit `Microsoft’s WinRM
site `__.
%package help
Summary: Development documents and examples for pywinrm
Provides: python3-pywinrm-doc
%description help
pywinrm is a Python client for the Windows Remote Management (WinRM)
service. It allows you to invoke commands on target Windows machines
from any machine that can run Python.
|License| |Test workflow| |Coverage| |PyPI|
WinRM allows you to perform various management tasks remotely. These
include, but are not limited to: running batch scripts, powershell
scripts, and fetching WMI variables.
Used by `Ansible `__ for Windows support.
For more information on WinRM, please visit `Microsoft’s WinRM
site `__.
%prep
%autosetup -n pywinrm-0.4.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pywinrm -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.4.3-1
- Package Spec generated