%global _empty_manifest_terminate_build 0
Name:		python-nose2
Version:	0.12.0
Release:	1
Summary:	unittest2 with plugins, the successor to nose
License:	BSD License
URL:		https://github.com/nose-devs/nose2
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6e/0e/7c8c0ddf8a8adf1f2af273a25867c6edd479ca1ee59d5fa6edc70ec249b3/nose2-0.12.0.tar.gz
BuildArch:	noarch

Requires:	python3-coverage
Requires:	python3-Sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-mock
Requires:	python3-sphinx-issues

%description
``nose2`` is the successor to ``nose``.
It's ``unittest`` with plugins.
``nose2`` is a new project and does not support all of the features of
``nose``. See `differences`_ for a thorough rundown.
nose2's purpose is to extend ``unittest`` to make testing nicer and easier to
understand.

%package -n python3-nose2
Summary:	unittest2 with plugins, the successor to nose
Provides:	python-nose2
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-nose2
``nose2`` is the successor to ``nose``.
It's ``unittest`` with plugins.
``nose2`` is a new project and does not support all of the features of
``nose``. See `differences`_ for a thorough rundown.
nose2's purpose is to extend ``unittest`` to make testing nicer and easier to
understand.

%package help
Summary:	Development documents and examples for nose2
Provides:	python3-nose2-doc
%description help
``nose2`` is the successor to ``nose``.
It's ``unittest`` with plugins.
``nose2`` is a new project and does not support all of the features of
``nose``. See `differences`_ for a thorough rundown.
nose2's purpose is to extend ``unittest`` to make testing nicer and easier to
understand.

%prep
%autosetup -n nose2-0.12.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-nose2 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.12.0-1
- Package Spec generated