%global _empty_manifest_terminate_build 0
Name: python-feedfinder2
Version: 0.0.4
Release: 1
Summary: Find the feed URLs for a website.
License: MIT
URL: https://github.com/dfm/feedfinder2
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/35/82/1251fefec3bb4b03fd966c7e7f7a41c9fc2bb00d823a34c13f847fd61406/feedfinder2-0.0.4.tar.gz
BuildArch: noarch
%description
This is a Python library for finding links feeds on a website. It is based on
`feedfinder `_ - originally
written by `Mark
Pilgrim `_ and
subsequently maintained by `Aaron
Swartz `_ until his untimely death.
%package -n python3-feedfinder2
Summary: Find the feed URLs for a website.
Provides: python-feedfinder2
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-feedfinder2
This is a Python library for finding links feeds on a website. It is based on
`feedfinder `_ - originally
written by `Mark
Pilgrim `_ and
subsequently maintained by `Aaron
Swartz `_ until his untimely death.
%package help
Summary: Development documents and examples for feedfinder2
Provides: python3-feedfinder2-doc
%description help
This is a Python library for finding links feeds on a website. It is based on
`feedfinder `_ - originally
written by `Mark
Pilgrim `_ and
subsequently maintained by `Aaron
Swartz `_ until his untimely death.
%prep
%autosetup -n feedfinder2-0.0.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-feedfinder2 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.0.4-1
- Package Spec generated