%global _empty_manifest_terminate_build 0
Name:		python-mir_eval
Version:	0.7
Release:	1
Summary:	Common metrics for common audio/music processing tasks.
License:	MIT
URL:		https://github.com/craffel/mir_eval
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6b/4b/2cf10b8f0b4bbd9206d871d591d4b5ab4909c1193644df9656d57d6cf978/mir_eval-0.7.tar.gz
BuildArch:	noarch


%description
Python library for computing common heuristic accuracy scores for various music/audio information retrieval/signal processing tasks.
Documentation, including installation and usage information: http://craffel.github.io/mir_eval/
If you're looking for the mir_eval web service, which you can use to run mir_eval without installing anything or writing any code, it can be found here: http://labrosa.ee.columbia.edu/mir_eval/
Dependencies:
* `Scipy/Numpy <http://www.scipy.org/>`_
* future
* six
If you use mir_eval in a research project, please cite the following paper:
Colin Raffel, Brian McFee, Eric J. Humphrey, Justin Salamon, Oriol Nieto, Dawen Liang, and Daniel P. W. Ellis, "`mir_eval: A Transparent Implementation of Common MIR Metrics <http://colinraffel.com/publications/ismir2014mir_eval.pdf>`_", Proceedings of the 15th International Conference on Music Information Retrieval, 2014.

%package -n python3-mir_eval
Summary:	Common metrics for common audio/music processing tasks.
Provides:	python-mir_eval
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-mir_eval
Python library for computing common heuristic accuracy scores for various music/audio information retrieval/signal processing tasks.
Documentation, including installation and usage information: http://craffel.github.io/mir_eval/
If you're looking for the mir_eval web service, which you can use to run mir_eval without installing anything or writing any code, it can be found here: http://labrosa.ee.columbia.edu/mir_eval/
Dependencies:
* `Scipy/Numpy <http://www.scipy.org/>`_
* future
* six
If you use mir_eval in a research project, please cite the following paper:
Colin Raffel, Brian McFee, Eric J. Humphrey, Justin Salamon, Oriol Nieto, Dawen Liang, and Daniel P. W. Ellis, "`mir_eval: A Transparent Implementation of Common MIR Metrics <http://colinraffel.com/publications/ismir2014mir_eval.pdf>`_", Proceedings of the 15th International Conference on Music Information Retrieval, 2014.

%package help
Summary:	Development documents and examples for mir_eval
Provides:	python3-mir_eval-doc
%description help
Python library for computing common heuristic accuracy scores for various music/audio information retrieval/signal processing tasks.
Documentation, including installation and usage information: http://craffel.github.io/mir_eval/
If you're looking for the mir_eval web service, which you can use to run mir_eval without installing anything or writing any code, it can be found here: http://labrosa.ee.columbia.edu/mir_eval/
Dependencies:
* `Scipy/Numpy <http://www.scipy.org/>`_
* future
* six
If you use mir_eval in a research project, please cite the following paper:
Colin Raffel, Brian McFee, Eric J. Humphrey, Justin Salamon, Oriol Nieto, Dawen Liang, and Daniel P. W. Ellis, "`mir_eval: A Transparent Implementation of Common MIR Metrics <http://colinraffel.com/publications/ismir2014mir_eval.pdf>`_", Proceedings of the 15th International Conference on Music Information Retrieval, 2014.

%prep
%autosetup -n mir_eval-0.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-mir_eval -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7-1
- Package Spec generated