%global _empty_manifest_terminate_build 0
Name: python-geospark
Version: 1.3.1
Release: 1
Summary: GeoSpark Python
License: Apache Software License
URL: https://github.com/DataSystemsLab/GeoSpark/tree/master/python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5a/5e/5be33368ec1a6d20674724c425c216761909b8526ff8740dbb2c1d3f7c41/geospark-1.3.1.tar.gz
BuildArch: noarch
Requires: python3-pyspark
Requires: python3-findspark
Requires: python3-attrs
Requires: python3-shapely
%description
# geospark
This library is Python wrapper on GeoSpark library.
GeoSpark is a cluster computing system for processing large-scale spatial data. GeoSpark extends Apache Spark / SparkSQL with a set of out-of-the-box Spatial Resilient Distributed Datasets (SRDDs)/ SpatialSQL that efficiently load, process, and analyze large-scale spatial data across machines.
Python version supports:
GeoSpark core
GeoSpark SQL
Please follow tutorial on official GeoSpark website:
https://datasystemslab.github.io/GeoSpark/
%package -n python3-geospark
Summary: GeoSpark Python
Provides: python-geospark
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-geospark
# geospark
This library is Python wrapper on GeoSpark library.
GeoSpark is a cluster computing system for processing large-scale spatial data. GeoSpark extends Apache Spark / SparkSQL with a set of out-of-the-box Spatial Resilient Distributed Datasets (SRDDs)/ SpatialSQL that efficiently load, process, and analyze large-scale spatial data across machines.
Python version supports:
GeoSpark core
GeoSpark SQL
Please follow tutorial on official GeoSpark website:
https://datasystemslab.github.io/GeoSpark/
%package help
Summary: Development documents and examples for geospark
Provides: python3-geospark-doc
%description help
# geospark
This library is Python wrapper on GeoSpark library.
GeoSpark is a cluster computing system for processing large-scale spatial data. GeoSpark extends Apache Spark / SparkSQL with a set of out-of-the-box Spatial Resilient Distributed Datasets (SRDDs)/ SpatialSQL that efficiently load, process, and analyze large-scale spatial data across machines.
Python version supports:
GeoSpark core
GeoSpark SQL
Please follow tutorial on official GeoSpark website:
https://datasystemslab.github.io/GeoSpark/
%prep
%autosetup -n geospark-1.3.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-geospark -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.3.1-1
- Package Spec generated