%global _empty_manifest_terminate_build 0
Name:		python-os-sys
Version:	2.1.4
Release:	1
Summary:	a big lib with many usefull tools and it are not only os and sys tools...
License:	GNU General Public License
URL:		https://github.com/Matthijs990/os-sys-github/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e7/1b/1b2e022722ef04cd9c831182fa5af0648e5d5cbe4aa911b74de85b984460/os_sys-2.1.4.tar.gz
BuildArch:	noarch

Requires:	python3-wmi
Requires:	python3-pygubu
Requires:	python3-pytz
Requires:	python3-sqlparse
Requires:	python3-progress
Requires:	python3-tqdm
Requires:	python3-progressbar
Requires:	python3-matplotlib
Requires:	python3-numpy
Requires:	python3-six
Requires:	python3-jupyter
Requires:	python3-pandas
Requires:	python3-beautifulsoup4
Requires:	python3-Eel
Requires:	python3-extract-zip
Requires:	python3-text-editor
Requires:	python3-tuspy
Requires:	python3-requests-download
Requires:	python3-requests
Requires:	python3-Send2Trash
Requires:	python3-tornado
Requires:	python3-pyspeedtest
Requires:	python3-pytest
Requires:	python3-wifi
Requires:	python3-PyInstaller
Requires:	python3-auto-py-to-exe
Requires:	python3-Django
Requires:	python3-mysql-connector
Requires:	python3-geocoder
Requires:	python3-selenium
Requires:	python3-psutil
Requires:	python3-pynput
Requires:	python3-pythonGui
Requires:	python3-pypiwin32
Requires:	python3-pyvalid
Requires:	python3-netifaces
Requires:	python3-cefpython3
Requires:	python3-mathparse
Requires:	python3-nltk
Requires:	python3-pint
Requires:	python3-dateutil
Requires:	python3-pyyaml
Requires:	python3-spacy
Requires:	python3-sqlalchemy
Requires:	python3-os-sys-php

%description
fixed:
os_sys.log: get_logger function
performance:
fixed some performance issues

%package -n python3-os-sys
Summary:	a big lib with many usefull tools and it are not only os and sys tools...
Provides:	python-os-sys
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-os-sys
fixed:
os_sys.log: get_logger function
performance:
fixed some performance issues

%package help
Summary:	Development documents and examples for os-sys
Provides:	python3-os-sys-doc
%description help
fixed:
os_sys.log: get_logger function
performance:
fixed some performance issues

%prep
%autosetup -n os-sys-2.1.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-os-sys -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.4-1
- Package Spec generated