%global _empty_manifest_terminate_build 0
Name: python-cdktf-cdktf-provider-azurerm
Version: 7.0.1
Release: 1
Summary: Prebuilt azurerm Provider for Terraform CDK (cdktf)
License: MPL-2.0
URL: https://github.com/cdktf/cdktf-provider-azurerm.git
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6b/6a/c7df342558fa12331f9e1be585808be601c9b4a890cedb9feb0aaac4e0e8/cdktf-cdktf-provider-azurerm-7.0.1.tar.gz
BuildArch: noarch
Requires: python3-cdktf
Requires: python3-constructs
Requires: python3-jsii
Requires: python3-publication
Requires: python3-typeguard
%description
# Terraform CDK azurerm Provider ~> 3.10
This repo builds and publishes the Terraform azurerm Provider bindings for [CDK for Terraform](https://cdk.tf).
## Available Packages
### NPM
The npm package is available at [https://www.npmjs.com/package/@cdktf/provider-azurerm](https://www.npmjs.com/package/@cdktf/provider-azurerm).
`npm install @cdktf/provider-azurerm`
### PyPI
The PyPI package is available at [https://pypi.org/project/cdktf-cdktf-provider-azurerm](https://pypi.org/project/cdktf-cdktf-provider-azurerm).
`pipenv install cdktf-cdktf-provider-azurerm`
### Nuget
The Nuget package is available at [https://www.nuget.org/packages/HashiCorp.Cdktf.Providers.Azurerm](https://www.nuget.org/packages/HashiCorp.Cdktf.Providers.Azurerm).
`dotnet add package HashiCorp.Cdktf.Providers.Azurerm`
### Maven
The Maven package is available at [https://mvnrepository.com/artifact/com.hashicorp/cdktf-provider-azurerm](https://mvnrepository.com/artifact/com.hashicorp/cdktf-provider-azurerm).
```
com.hashicorp
cdktf-provider-azurerm
[REPLACE WITH DESIRED VERSION]
```
### Go
The go package is generated into the [`github.com/cdktf/cdktf-provider-azurerm-go`](https://github.com/cdktf/cdktf-provider-azurerm-go) package.
`go get github.com/cdktf/cdktf-provider-azurerm-go/azurerm`
## Docs
Find auto-generated docs for this provider here:
* [Typescript](./docs/API.typescript.md)
* [Python](./docs/API.python.md)
* [Java](./docs/API.java.md)
* [C#](./docs/API.csharp.md)
* [Go](./docs/API.go.md)
You can also visit a hosted version of the documentation on [constructs.dev](https://constructs.dev/packages/@cdktf/provider-azurerm).
## Versioning
This project is explicitly not tracking the Terraform azurerm Provider version 1:1. In fact, it always tracks `latest` of `~> 3.10` with every release. If there are scenarios where you explicitly have to pin your provider version, you can do so by generating the [provider constructs manually](https://cdk.tf/imports).
These are the upstream dependencies:
* [Terraform CDK](https://cdk.tf)
* [Terraform azurerm Provider](https://github.com/terraform-providers/terraform-provider-azurerm)
* [Terraform Engine](https://terraform.io)
If there are breaking changes (backward incompatible) in any of the above, the major version of this project will be bumped.
## Features / Issues / Bugs
Please report bugs and issues to the [terraform cdk](https://cdk.tf) project:
* [Create bug report](https://cdk.tf/bug)
* [Create feature request](https://cdk.tf/feature)
## Contributing
### projen
This is mostly based on [projen](https://github.com/eladb/projen), which takes care of generating the entire repository.
### cdktf-provider-project based on projen
There's a custom [project builder](https://github.com/hashicorp/cdktf-provider-project) which encapsulate the common settings for all `cdktf` providers.
### Provider Version
The provider version can be adjusted in [./.projenrc.js](./.projenrc.js).
### Repository Management
The repository is managed by [Repository Manager](https://github.com/hashicorp/cdktf-repository-manager/)
%package -n python3-cdktf-cdktf-provider-azurerm
Summary: Prebuilt azurerm Provider for Terraform CDK (cdktf)
Provides: python-cdktf-cdktf-provider-azurerm
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cdktf-cdktf-provider-azurerm
# Terraform CDK azurerm Provider ~> 3.10
This repo builds and publishes the Terraform azurerm Provider bindings for [CDK for Terraform](https://cdk.tf).
## Available Packages
### NPM
The npm package is available at [https://www.npmjs.com/package/@cdktf/provider-azurerm](https://www.npmjs.com/package/@cdktf/provider-azurerm).
`npm install @cdktf/provider-azurerm`
### PyPI
The PyPI package is available at [https://pypi.org/project/cdktf-cdktf-provider-azurerm](https://pypi.org/project/cdktf-cdktf-provider-azurerm).
`pipenv install cdktf-cdktf-provider-azurerm`
### Nuget
The Nuget package is available at [https://www.nuget.org/packages/HashiCorp.Cdktf.Providers.Azurerm](https://www.nuget.org/packages/HashiCorp.Cdktf.Providers.Azurerm).
`dotnet add package HashiCorp.Cdktf.Providers.Azurerm`
### Maven
The Maven package is available at [https://mvnrepository.com/artifact/com.hashicorp/cdktf-provider-azurerm](https://mvnrepository.com/artifact/com.hashicorp/cdktf-provider-azurerm).
```
com.hashicorp
cdktf-provider-azurerm
[REPLACE WITH DESIRED VERSION]
```
### Go
The go package is generated into the [`github.com/cdktf/cdktf-provider-azurerm-go`](https://github.com/cdktf/cdktf-provider-azurerm-go) package.
`go get github.com/cdktf/cdktf-provider-azurerm-go/azurerm`
## Docs
Find auto-generated docs for this provider here:
* [Typescript](./docs/API.typescript.md)
* [Python](./docs/API.python.md)
* [Java](./docs/API.java.md)
* [C#](./docs/API.csharp.md)
* [Go](./docs/API.go.md)
You can also visit a hosted version of the documentation on [constructs.dev](https://constructs.dev/packages/@cdktf/provider-azurerm).
## Versioning
This project is explicitly not tracking the Terraform azurerm Provider version 1:1. In fact, it always tracks `latest` of `~> 3.10` with every release. If there are scenarios where you explicitly have to pin your provider version, you can do so by generating the [provider constructs manually](https://cdk.tf/imports).
These are the upstream dependencies:
* [Terraform CDK](https://cdk.tf)
* [Terraform azurerm Provider](https://github.com/terraform-providers/terraform-provider-azurerm)
* [Terraform Engine](https://terraform.io)
If there are breaking changes (backward incompatible) in any of the above, the major version of this project will be bumped.
## Features / Issues / Bugs
Please report bugs and issues to the [terraform cdk](https://cdk.tf) project:
* [Create bug report](https://cdk.tf/bug)
* [Create feature request](https://cdk.tf/feature)
## Contributing
### projen
This is mostly based on [projen](https://github.com/eladb/projen), which takes care of generating the entire repository.
### cdktf-provider-project based on projen
There's a custom [project builder](https://github.com/hashicorp/cdktf-provider-project) which encapsulate the common settings for all `cdktf` providers.
### Provider Version
The provider version can be adjusted in [./.projenrc.js](./.projenrc.js).
### Repository Management
The repository is managed by [Repository Manager](https://github.com/hashicorp/cdktf-repository-manager/)
%package help
Summary: Development documents and examples for cdktf-cdktf-provider-azurerm
Provides: python3-cdktf-cdktf-provider-azurerm-doc
%description help
# Terraform CDK azurerm Provider ~> 3.10
This repo builds and publishes the Terraform azurerm Provider bindings for [CDK for Terraform](https://cdk.tf).
## Available Packages
### NPM
The npm package is available at [https://www.npmjs.com/package/@cdktf/provider-azurerm](https://www.npmjs.com/package/@cdktf/provider-azurerm).
`npm install @cdktf/provider-azurerm`
### PyPI
The PyPI package is available at [https://pypi.org/project/cdktf-cdktf-provider-azurerm](https://pypi.org/project/cdktf-cdktf-provider-azurerm).
`pipenv install cdktf-cdktf-provider-azurerm`
### Nuget
The Nuget package is available at [https://www.nuget.org/packages/HashiCorp.Cdktf.Providers.Azurerm](https://www.nuget.org/packages/HashiCorp.Cdktf.Providers.Azurerm).
`dotnet add package HashiCorp.Cdktf.Providers.Azurerm`
### Maven
The Maven package is available at [https://mvnrepository.com/artifact/com.hashicorp/cdktf-provider-azurerm](https://mvnrepository.com/artifact/com.hashicorp/cdktf-provider-azurerm).
```
com.hashicorp
cdktf-provider-azurerm
[REPLACE WITH DESIRED VERSION]
```
### Go
The go package is generated into the [`github.com/cdktf/cdktf-provider-azurerm-go`](https://github.com/cdktf/cdktf-provider-azurerm-go) package.
`go get github.com/cdktf/cdktf-provider-azurerm-go/azurerm`
## Docs
Find auto-generated docs for this provider here:
* [Typescript](./docs/API.typescript.md)
* [Python](./docs/API.python.md)
* [Java](./docs/API.java.md)
* [C#](./docs/API.csharp.md)
* [Go](./docs/API.go.md)
You can also visit a hosted version of the documentation on [constructs.dev](https://constructs.dev/packages/@cdktf/provider-azurerm).
## Versioning
This project is explicitly not tracking the Terraform azurerm Provider version 1:1. In fact, it always tracks `latest` of `~> 3.10` with every release. If there are scenarios where you explicitly have to pin your provider version, you can do so by generating the [provider constructs manually](https://cdk.tf/imports).
These are the upstream dependencies:
* [Terraform CDK](https://cdk.tf)
* [Terraform azurerm Provider](https://github.com/terraform-providers/terraform-provider-azurerm)
* [Terraform Engine](https://terraform.io)
If there are breaking changes (backward incompatible) in any of the above, the major version of this project will be bumped.
## Features / Issues / Bugs
Please report bugs and issues to the [terraform cdk](https://cdk.tf) project:
* [Create bug report](https://cdk.tf/bug)
* [Create feature request](https://cdk.tf/feature)
## Contributing
### projen
This is mostly based on [projen](https://github.com/eladb/projen), which takes care of generating the entire repository.
### cdktf-provider-project based on projen
There's a custom [project builder](https://github.com/hashicorp/cdktf-provider-project) which encapsulate the common settings for all `cdktf` providers.
### Provider Version
The provider version can be adjusted in [./.projenrc.js](./.projenrc.js).
### Repository Management
The repository is managed by [Repository Manager](https://github.com/hashicorp/cdktf-repository-manager/)
%prep
%autosetup -n cdktf-cdktf-provider-azurerm-7.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cdktf-cdktf-provider-azurerm -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 7.0.1-1
- Package Spec generated