%global _empty_manifest_terminate_build 0
Name:		python-ed25519
Version:	1.5
Release:	1
Summary:	Ed25519 public-key signatures
License:	MIT
URL:		https://github.com/warner/python-ed25519
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/58/38/72ec85c953b90552fb015f31248256ef19e89a164a40ff8fef680259a608/ed25519-1.5.tar.gz
BuildArch:	noarch


%description
Python bindings to the Ed25519 public-key signature system.

This offers a comfortable python interface to a C implementation of the
Ed25519 public-key signature system (http://ed25519.cr.yp.to/), using the
portable 'ref' code from the 'SUPERCOP' benchmarking suite.

This system provides high (128-bit) security, short (32-byte) keys, short
(64-byte) signatures, and fast (2-6ms) operation. Please see the README for
more details.

## Not Recommended For New Applications: Use pynacl Instead

For new applications, I recommend you use
[`pynacl`](https://github.com/pyca/pynacl) instead of this repository.
`PyNaCl` is larger and takes longer to build (it contains the complete
NaCl/libsodium library, not just the ed25519 portion), but it is
well-maintained by the diligent and conscientious PyCA team, whereas I've
allowed this repository to languish. `PyNaCl` is also about 10-20 times
faster. A guide for migration fron `python-ed25519` to `PyNaCl` is included
below.

%package -n python3-ed25519
Summary:	Ed25519 public-key signatures
Provides:	python-ed25519
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ed25519
Python bindings to the Ed25519 public-key signature system.

This offers a comfortable python interface to a C implementation of the
Ed25519 public-key signature system (http://ed25519.cr.yp.to/), using the
portable 'ref' code from the 'SUPERCOP' benchmarking suite.

This system provides high (128-bit) security, short (32-byte) keys, short
(64-byte) signatures, and fast (2-6ms) operation. Please see the README for
more details.

## Not Recommended For New Applications: Use pynacl Instead

For new applications, I recommend you use
[`pynacl`](https://github.com/pyca/pynacl) instead of this repository.
`PyNaCl` is larger and takes longer to build (it contains the complete
NaCl/libsodium library, not just the ed25519 portion), but it is
well-maintained by the diligent and conscientious PyCA team, whereas I've
allowed this repository to languish. `PyNaCl` is also about 10-20 times
faster. A guide for migration fron `python-ed25519` to `PyNaCl` is included
below.

%package help
Summary:	Development documents and examples for ed25519
Provides:	python3-ed25519-doc
%description help
Python bindings to the Ed25519 public-key signature system.

This offers a comfortable python interface to a C implementation of the
Ed25519 public-key signature system (http://ed25519.cr.yp.to/), using the
portable 'ref' code from the 'SUPERCOP' benchmarking suite.

This system provides high (128-bit) security, short (32-byte) keys, short
(64-byte) signatures, and fast (2-6ms) operation. Please see the README for
more details.

## Not Recommended For New Applications: Use pynacl Instead

For new applications, I recommend you use
[`pynacl`](https://github.com/pyca/pynacl) instead of this repository.
`PyNaCl` is larger and takes longer to build (it contains the complete
NaCl/libsodium library, not just the ed25519 portion), but it is
well-maintained by the diligent and conscientious PyCA team, whereas I've
allowed this repository to languish. `PyNaCl` is also about 10-20 times
faster. A guide for migration fron `python-ed25519` to `PyNaCl` is included
below.

%prep
%autosetup -n ed25519-1.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ed25519 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5-1
- Package Spec generated