%global _empty_manifest_terminate_build 0
Name:		python-pydomo
Version:	0.3.0.9
Release:	1
Summary:	The official Python3 Domo API SDK - Domo, Inc.
License:	MIT
URL:		https://github.com/domoinc/domo-python-sdk
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2d/21/635c240226311802df84f356145ee6c3e7196c96dfe2a643e3e6c7ff1fe3/pydomo-0.3.0.9.tar.gz
BuildArch:	noarch

Requires:	python3-pandas
Requires:	python3-requests
Requires:	python3-requests-toolbelt

%description
See https://github.com/domoinc/domo-python-sdk for more details.


%package -n python3-pydomo
Summary:	The official Python3 Domo API SDK - Domo, Inc.
Provides:	python-pydomo
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pydomo
See https://github.com/domoinc/domo-python-sdk for more details.


%package help
Summary:	Development documents and examples for pydomo
Provides:	python3-pydomo-doc
%description help
See https://github.com/domoinc/domo-python-sdk for more details.


%prep
%autosetup -n pydomo-0.3.0.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pydomo -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0.9-1
- Package Spec generated