%global _empty_manifest_terminate_build 0
Name:		python-ics
Version:	0.7.2
Release:	1
Summary:	Python icalendar (rfc5545) parser
License:	Apache License, Version 2.0
URL:		http://github.com/C4ptainCrunch/ics.py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/43/fa/2cb7cbe23566140f011da4fec280d4873da4389c8b838bb3e5ce3fc39b16/ics-0.7.2.tar.gz
BuildArch:	noarch

Requires:	python3-dateutil
Requires:	python3-arrow
Requires:	python3-six
Requires:	python3-tatsu
Requires:	python3-attrs

%description
`Original repository <https://github.com/C4ptainCrunch/ics.py>`_ (GitHub) -
`Bugtracker and issues <https://github.com/C4ptainCrunch/ics.py/issues>`_ (GitHub) -
`PyPi package <https://pypi.python.org/pypi/ics/>`_ (ics) -
`Documentation <http://icspy.readthedocs.org/>`_ (Read The Docs).
Ics.py is a pythonic and easy iCalendar library.
Its goals are to read and write ics data in a developer friendly way.
iCalendar is a widely-used and useful format but not user friendly.
Ics.py is there to give you the ability of creating and reading this
format without any knowledge of it.
It should be able to parse every calendar that respects the
`rfc5545 <http://tools.ietf.org/html/rfc5545>`_ and maybe some more…
It also outputs rfc compliant calendars.
iCalendar (file extension `.ics`) is used by Google Calendar,
Apple Calendar, Android and many more.
Ics.py is available for Python>=3.6 and is Apache2 Licensed.

%package -n python3-ics
Summary:	Python icalendar (rfc5545) parser
Provides:	python-ics
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ics
`Original repository <https://github.com/C4ptainCrunch/ics.py>`_ (GitHub) -
`Bugtracker and issues <https://github.com/C4ptainCrunch/ics.py/issues>`_ (GitHub) -
`PyPi package <https://pypi.python.org/pypi/ics/>`_ (ics) -
`Documentation <http://icspy.readthedocs.org/>`_ (Read The Docs).
Ics.py is a pythonic and easy iCalendar library.
Its goals are to read and write ics data in a developer friendly way.
iCalendar is a widely-used and useful format but not user friendly.
Ics.py is there to give you the ability of creating and reading this
format without any knowledge of it.
It should be able to parse every calendar that respects the
`rfc5545 <http://tools.ietf.org/html/rfc5545>`_ and maybe some more…
It also outputs rfc compliant calendars.
iCalendar (file extension `.ics`) is used by Google Calendar,
Apple Calendar, Android and many more.
Ics.py is available for Python>=3.6 and is Apache2 Licensed.

%package help
Summary:	Development documents and examples for ics
Provides:	python3-ics-doc
%description help
`Original repository <https://github.com/C4ptainCrunch/ics.py>`_ (GitHub) -
`Bugtracker and issues <https://github.com/C4ptainCrunch/ics.py/issues>`_ (GitHub) -
`PyPi package <https://pypi.python.org/pypi/ics/>`_ (ics) -
`Documentation <http://icspy.readthedocs.org/>`_ (Read The Docs).
Ics.py is a pythonic and easy iCalendar library.
Its goals are to read and write ics data in a developer friendly way.
iCalendar is a widely-used and useful format but not user friendly.
Ics.py is there to give you the ability of creating and reading this
format without any knowledge of it.
It should be able to parse every calendar that respects the
`rfc5545 <http://tools.ietf.org/html/rfc5545>`_ and maybe some more…
It also outputs rfc compliant calendars.
iCalendar (file extension `.ics`) is used by Google Calendar,
Apple Calendar, Android and many more.
Ics.py is available for Python>=3.6 and is Apache2 Licensed.

%prep
%autosetup -n ics-0.7.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ics -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.2-1
- Package Spec generated