%global _empty_manifest_terminate_build 0
Name: python-psycopg2-pool
Version: 1.1
Release: 1
Summary: Proper pooling of psycopg2 connections
License: LGPL3
URL: https://github.com/Changaco/psycopg2-pool
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/15/9d/fcbc892ef52d4f7a4b82dab5c5055bfbad0d3a0217c3461e472c7d87367a/psycopg2-pool-1.1.tar.gz
BuildArch: noarch
Requires: python3-psycopg2-binary
%description
See the documentation at .
# Changelog
## 1.1 (October 8, 2019)
- [Fixes the discarding of extraneous connections](https://github.com/Changaco/psycopg2-pool/pull/1)
- [Fixes `ThreadSafeConnectionPool.__slots__`](https://github.com/Changaco/psycopg2-pool/commit/0145f44efc21a2e1ec078c6d29a4649f9978380f)
## 1.0 (October 6, 2019)
Initial release.
%package -n python3-psycopg2-pool
Summary: Proper pooling of psycopg2 connections
Provides: python-psycopg2-pool
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-psycopg2-pool
See the documentation at .
# Changelog
## 1.1 (October 8, 2019)
- [Fixes the discarding of extraneous connections](https://github.com/Changaco/psycopg2-pool/pull/1)
- [Fixes `ThreadSafeConnectionPool.__slots__`](https://github.com/Changaco/psycopg2-pool/commit/0145f44efc21a2e1ec078c6d29a4649f9978380f)
## 1.0 (October 6, 2019)
Initial release.
%package help
Summary: Development documents and examples for psycopg2-pool
Provides: python3-psycopg2-pool-doc
%description help
See the documentation at .
# Changelog
## 1.1 (October 8, 2019)
- [Fixes the discarding of extraneous connections](https://github.com/Changaco/psycopg2-pool/pull/1)
- [Fixes `ThreadSafeConnectionPool.__slots__`](https://github.com/Changaco/psycopg2-pool/commit/0145f44efc21a2e1ec078c6d29a4649f9978380f)
## 1.0 (October 6, 2019)
Initial release.
%prep
%autosetup -n psycopg2-pool-1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-psycopg2-pool -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.1-1
- Package Spec generated