%global _empty_manifest_terminate_build 0
Name:		python-ultimate-hosts-blacklist-helpers
Version:	1.20.1
Release:	1
Summary:	The helpers classes/functions of the Ultimate Hosts Blacklist project.
License:	MIT
URL:		https://github.com/Ultimate-Hosts-Blacklist/dev-center/tree/helpers
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d9/30/33071bdb419ccf9a3e1717ec01050329fb6ad06bb320cd80e26e0f0134c2/ultimate-hosts-blacklist-helpers-1.20.1.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-pyyaml

%description
This is the branch which contain the helpers which we use while developing submodule for our infrastructure or frontend.

%package -n python3-ultimate-hosts-blacklist-helpers
Summary:	The helpers classes/functions of the Ultimate Hosts Blacklist project.
Provides:	python-ultimate-hosts-blacklist-helpers
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ultimate-hosts-blacklist-helpers
This is the branch which contain the helpers which we use while developing submodule for our infrastructure or frontend.

%package help
Summary:	Development documents and examples for ultimate-hosts-blacklist-helpers
Provides:	python3-ultimate-hosts-blacklist-helpers-doc
%description help
This is the branch which contain the helpers which we use while developing submodule for our infrastructure or frontend.

%prep
%autosetup -n ultimate-hosts-blacklist-helpers-1.20.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ultimate-hosts-blacklist-helpers -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 1.20.1-1
- Package Spec generated