%global _empty_manifest_terminate_build 0
Name: python-sphinx-automodapi
Version: 0.15.0
Release: 1
Summary: Sphinx extension for auto-generating API documentation for entire modules
License: BSD 3-Clause License
URL: https://github.com/astropy/sphinx-automodapi
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6c/75/f88a689907b603994d7b465ec83453c1db3899e4bf3814d4ffec04b5d7af/sphinx-automodapi-0.15.0.tar.gz
BuildArch: noarch
Requires: python3-sphinx
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-cython
Requires: python3-codecov
Requires: python3-coverage
%description
This is a Sphinx extension to automatically generate API pages for whole
modules. It was originally developed for the Astropy project but is now
available as a standalone package since it can be used for any other
package. The documentation can be found on
`ReadTheDocs `_.
%package -n python3-sphinx-automodapi
Summary: Sphinx extension for auto-generating API documentation for entire modules
Provides: python-sphinx-automodapi
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sphinx-automodapi
This is a Sphinx extension to automatically generate API pages for whole
modules. It was originally developed for the Astropy project but is now
available as a standalone package since it can be used for any other
package. The documentation can be found on
`ReadTheDocs `_.
%package help
Summary: Development documents and examples for sphinx-automodapi
Provides: python3-sphinx-automodapi-doc
%description help
This is a Sphinx extension to automatically generate API pages for whole
modules. It was originally developed for the Astropy project but is now
available as a standalone package since it can be used for any other
package. The documentation can be found on
`ReadTheDocs `_.
%prep
%autosetup -n sphinx-automodapi-0.15.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sphinx-automodapi -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.15.0-1
- Package Spec generated