%global _empty_manifest_terminate_build 0
Name: python-slimit
Version: 0.8.1
Release: 1
Summary: SlimIt - JavaScript minifier
License: MIT
URL: http://slimit.readthedocs.org
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/61/cf/0d6598b1ceb463a46b75a716fbb23d2d5ccc5738aba8ddceeec3fa59997f/slimit-0.8.1.zip
BuildArch: noarch
%description
`SlimIt` is a JavaScript minifier written in Python.
It compiles JavaScript into more compact code so that it downloads
and runs faster.
`SlimIt` also provides a library that includes a JavaScript parser,
lexer, pretty printer and a tree visitor.
`http://slimit.readthedocs.org/ `_
%package -n python3-slimit
Summary: SlimIt - JavaScript minifier
Provides: python-slimit
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-slimit
`SlimIt` is a JavaScript minifier written in Python.
It compiles JavaScript into more compact code so that it downloads
and runs faster.
`SlimIt` also provides a library that includes a JavaScript parser,
lexer, pretty printer and a tree visitor.
`http://slimit.readthedocs.org/ `_
%package help
Summary: Development documents and examples for slimit
Provides: python3-slimit-doc
%description help
`SlimIt` is a JavaScript minifier written in Python.
It compiles JavaScript into more compact code so that it downloads
and runs faster.
`SlimIt` also provides a library that includes a JavaScript parser,
lexer, pretty printer and a tree visitor.
`http://slimit.readthedocs.org/ `_
%prep
%autosetup -n slimit-0.8.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-slimit -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.8.1-1
- Package Spec generated