%global _empty_manifest_terminate_build 0
Name:		python-thug
Version:	4.9
Release:	1
Summary:	Low-interaction honeyclient Thug
License:	GPLv2
URL:		https://pypi.org/project/thug/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/19/ce/dc0e5579ebf3447e6f9fb30617c9d8e8c5c7f5e0c8cb19b837f5fb413832/thug-4.9.tar.gz
BuildArch:	noarch


%description
|version badge| |github badge| |codefactor badge| |codecov badge| |bandit badge|
The number of client-side attacks has grown significantly in the past few years
shifting focus on poorly protected vulnerable clients. Just as the most known
honeypot technologies enable research into server-side attacks, honeyclients
allow the study of client-side attacks.
A complement to honeypots, a honeyclient is a tool designed to mimic the behavior
of a user-driven network client application, such as a web browser, and be
exploited by an attacker's content.
Thug is a Python low-interaction honeyclient aimed at mimicking the behavior of a
web browser in order to detect and emulate malicious contents.

%package -n python3-thug
Summary:	Low-interaction honeyclient Thug
Provides:	python-thug
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-thug
|version badge| |github badge| |codefactor badge| |codecov badge| |bandit badge|
The number of client-side attacks has grown significantly in the past few years
shifting focus on poorly protected vulnerable clients. Just as the most known
honeypot technologies enable research into server-side attacks, honeyclients
allow the study of client-side attacks.
A complement to honeypots, a honeyclient is a tool designed to mimic the behavior
of a user-driven network client application, such as a web browser, and be
exploited by an attacker's content.
Thug is a Python low-interaction honeyclient aimed at mimicking the behavior of a
web browser in order to detect and emulate malicious contents.

%package help
Summary:	Development documents and examples for thug
Provides:	python3-thug-doc
%description help
|version badge| |github badge| |codefactor badge| |codecov badge| |bandit badge|
The number of client-side attacks has grown significantly in the past few years
shifting focus on poorly protected vulnerable clients. Just as the most known
honeypot technologies enable research into server-side attacks, honeyclients
allow the study of client-side attacks.
A complement to honeypots, a honeyclient is a tool designed to mimic the behavior
of a user-driven network client application, such as a web browser, and be
exploited by an attacker's content.
Thug is a Python low-interaction honeyclient aimed at mimicking the behavior of a
web browser in order to detect and emulate malicious contents.

%prep
%autosetup -n thug-4.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-thug -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 4.9-1
- Package Spec generated