%global _empty_manifest_terminate_build 0
Name: python-stix2
Version: 3.0.1
Release: 1
Summary: Produce and consume STIX 2 JSON content
License: BSD
URL: https://oasis-open.github.io/cti-documentation/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f6/6c/598c368b2822783179b0e7992877a3d4b4a7aded18244c1ed1db4894d729/stix2-3.0.1.tar.gz
BuildArch: noarch
Requires: python3-pytz
Requires: python3-requests
Requires: python3-simplejson
Requires: python3-stix2-patterns
Requires: python3-haversine
Requires: python3-rapidfuzz
Requires: python3-taxii2-client
%description
This is an `OASIS TC Open Repository `__.
See the `Governance <#governance>`__ section for more information.
This repository provides Python APIs for serializing and de-serializing STIX2
JSON content, along with higher-level APIs for common tasks, including data
markings, versioning, and for resolving STIX IDs across multiple data sources.
For more information, see `the documentation `__ on ReadTheDocs.
%package -n python3-stix2
Summary: Produce and consume STIX 2 JSON content
Provides: python-stix2
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-stix2
This is an `OASIS TC Open Repository `__.
See the `Governance <#governance>`__ section for more information.
This repository provides Python APIs for serializing and de-serializing STIX2
JSON content, along with higher-level APIs for common tasks, including data
markings, versioning, and for resolving STIX IDs across multiple data sources.
For more information, see `the documentation `__ on ReadTheDocs.
%package help
Summary: Development documents and examples for stix2
Provides: python3-stix2-doc
%description help
This is an `OASIS TC Open Repository `__.
See the `Governance <#governance>`__ section for more information.
This repository provides Python APIs for serializing and de-serializing STIX2
JSON content, along with higher-level APIs for common tasks, including data
markings, versioning, and for resolving STIX IDs across multiple data sources.
For more information, see `the documentation `__ on ReadTheDocs.
%prep
%autosetup -n stix2-3.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-stix2 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 3.0.1-1
- Package Spec generated