%global _empty_manifest_terminate_build 0
Name:		python-pyffx
Version:	0.3.0
Release:	1
Summary:	pure Python format preserving encryption
License:	MIT License
URL:		http://github.com/emulbreh/pyffx/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d3/0d/5d171254579c1595f7fe7df25a566184dce241c991d2211aaf7ed530b5b6/pyffx-0.3.0.tar.gz
BuildArch:	noarch


%description
pyffx is a pure Python implementation of *Format-preserving, Feistel-based encryption* (FFX).
* `The FFX Mode of Operation for Format-Preserving Encryption`_
* `Addendum to “The FFX Mode of Operation for Format-Preserving Encryption”`_
Only method 2 is implemented.
See also `libffx`_

%package -n python3-pyffx
Summary:	pure Python format preserving encryption
Provides:	python-pyffx
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyffx
pyffx is a pure Python implementation of *Format-preserving, Feistel-based encryption* (FFX).
* `The FFX Mode of Operation for Format-Preserving Encryption`_
* `Addendum to “The FFX Mode of Operation for Format-Preserving Encryption”`_
Only method 2 is implemented.
See also `libffx`_

%package help
Summary:	Development documents and examples for pyffx
Provides:	python3-pyffx-doc
%description help
pyffx is a pure Python implementation of *Format-preserving, Feistel-based encryption* (FFX).
* `The FFX Mode of Operation for Format-Preserving Encryption`_
* `Addendum to “The FFX Mode of Operation for Format-Preserving Encryption”`_
Only method 2 is implemented.
See also `libffx`_

%prep
%autosetup -n pyffx-0.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyffx -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
- Package Spec generated