%global _empty_manifest_terminate_build 0
Name:		python-super-csv
Version:	3.0.1
Release:	1
Summary:	CSV Processor
License:	Apache 2.0
URL:		https://github.com/edx/super-csv
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/5f/ec/e2c8865c4d3572e5723044832d8dd48621961a93d7cb76c7cb7ccf98e705/super-csv-3.0.1.tar.gz
BuildArch:	noarch

Requires:	python3-edx-django-utils
Requires:	python3-djangorestframework
Requires:	python3-edx-celeryutils
Requires:	python3-django-crum
Requires:	python3-Django
Requires:	python3-simplejson
Requires:	python3-django-model-utils

%description
|pypi-badge| |CI| |codecov-badge| |doc-badge| |pyversions-badge|
|license-badge|
Generic CSV Processing for Django Apps

%package -n python3-super-csv
Summary:	CSV Processor
Provides:	python-super-csv
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-super-csv
|pypi-badge| |CI| |codecov-badge| |doc-badge| |pyversions-badge|
|license-badge|
Generic CSV Processing for Django Apps

%package help
Summary:	Development documents and examples for super-csv
Provides:	python3-super-csv-doc
%description help
|pypi-badge| |CI| |codecov-badge| |doc-badge| |pyversions-badge|
|license-badge|
Generic CSV Processing for Django Apps

%prep
%autosetup -n super-csv-3.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-super-csv -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.1-1
- Package Spec generated