%global _empty_manifest_terminate_build 0
Name:		python-pytest-recording
Version:	0.12.2
Release:	1
Summary:	A pytest plugin that allows you recording of network interactions via VCR.py
License:	MIT
URL:		https://github.com/kiwicom/pytest-recording
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6c/f4/2f74cd201d2019b305eeedb4b220449a5139113aea8901dd59b1d0224f7f/pytest-recording-0.12.2.tar.gz
BuildArch:	noarch

Requires:	python3-vcrpy
Requires:	python3-pytest
Requires:	python3-attrs

%description
|codecov| |Build| |Version| |Python versions| |License|
A pytest plugin that records network interactions in your tests via VCR.py.

%package -n python3-pytest-recording
Summary:	A pytest plugin that allows you recording of network interactions via VCR.py
Provides:	python-pytest-recording
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pytest-recording
|codecov| |Build| |Version| |Python versions| |License|
A pytest plugin that records network interactions in your tests via VCR.py.

%package help
Summary:	Development documents and examples for pytest-recording
Provides:	python3-pytest-recording-doc
%description help
|codecov| |Build| |Version| |Python versions| |License|
A pytest plugin that records network interactions in your tests via VCR.py.

%prep
%autosetup -n pytest-recording-0.12.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pytest-recording -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.12.2-1
- Package Spec generated