%global _empty_manifest_terminate_build 0
Name: python-mdx-truly-sane-lists
Version: 1.3
Release: 1
Summary: Extension for Python-Markdown that makes lists truly sane. Custom indents for nested lists and fix for messy linebreaks.
License: MIT
URL: https://github.com/radude/mdx_truly_sane_lists
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e6/27/16456314311abac2cedef4527679924e80ac4de19dd926699c1b261e0b9b/mdx_truly_sane_lists-1.3.tar.gz
BuildArch: noarch
Requires: python3-Markdown
%description
# Mdx Truly Sane Lists
[![Build Status](https://travis-ci.org/radude/mdx_truly_sane_lists.svg?branch=master)](https://travis-ci.org/radude/mdx_truly_sane_lists)
An extension for [Python-Markdown](https://github.com/Python-Markdown/markdown) that makes lists truly sane. Features custom indents for nested lists and fix for messy linebreaks and paragraphs between lists.
## Features
* `nested_indent` option: Custom indent for nested lists. Defaults to `2`. Doesn't mess with code indents, which is still 4.
* `truly_sane` option: Makes linebreaks and paragraphs in lists behave as usually expected by user. No longer adds weird `p`, no extra linebreaks, no longer fuses lists together when they shouldn't be fused (see screenshots and examples below). Defaults to `True`.
* Inherits [sane lists](https://python-markdown.github.io/extensions/sane_lists/) behavior, which doesn't allow the mixing of ordered and unordered lists.
## Installation
##### [Pypi](https://pypi.python.org/pypi/mdx-truly-sane-lists):
```console
pip3 install mdx_truly_sane_lists
```
##### Directly from git:
```console
pip3 install git+git://github.com/radude/mdx_truly_sane_lists
```
## Usage
Basic:
```python
from markdown import markdown
# Default config is truly_sane: True, nested_indent: 2
markdown(text='some text', extensions=['mdx_truly_sane_lists'])
```
With explicit config:
```python
from markdown import markdown
markdown(text='some text',
extensions=[
'mdx_truly_sane_lists',
],
extension_configs={
'mdx_truly_sane_lists': {
'nested_indent': 2,
'truly_sane': True,
}},
)
```
## Screenshots and examples
You can preview the new behaviour live at [rentry.co](https://rentry.co/) (uses `nested_indent: 2, truly_sane: True`)
Some ugly screenshots because I'm lazy and cannot into gimp:
![](https://i.imgur.com/7l2bWLY.png)
![](https://i.imgur.com/Ruwfb2A.png)
## HTML
Data:
```markdown
- attributes
- customer
- first_name
- family_name
- email
- person
- first_name
- family_name
- birth_date
- subscription_id
- request
```
No extension:
```html before
-
attributes
-
customer
- first_name
- family_name
- email
- person
- first_name
- family_name
- birth_date
-
subscription_id
-
request
```
Truly sane + 4 spaces:
```html
- customer
- first_name
- family_name
- email
- person
- first_name
- family_name
- birth_date
- subscription_id
```
%package -n python3-mdx-truly-sane-lists
Summary: Extension for Python-Markdown that makes lists truly sane. Custom indents for nested lists and fix for messy linebreaks.
Provides: python-mdx-truly-sane-lists
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mdx-truly-sane-lists
# Mdx Truly Sane Lists
[![Build Status](https://travis-ci.org/radude/mdx_truly_sane_lists.svg?branch=master)](https://travis-ci.org/radude/mdx_truly_sane_lists)
An extension for [Python-Markdown](https://github.com/Python-Markdown/markdown) that makes lists truly sane. Features custom indents for nested lists and fix for messy linebreaks and paragraphs between lists.
## Features
* `nested_indent` option: Custom indent for nested lists. Defaults to `2`. Doesn't mess with code indents, which is still 4.
* `truly_sane` option: Makes linebreaks and paragraphs in lists behave as usually expected by user. No longer adds weird `p`, no extra linebreaks, no longer fuses lists together when they shouldn't be fused (see screenshots and examples below). Defaults to `True`.
* Inherits [sane lists](https://python-markdown.github.io/extensions/sane_lists/) behavior, which doesn't allow the mixing of ordered and unordered lists.
## Installation
##### [Pypi](https://pypi.python.org/pypi/mdx-truly-sane-lists):
```console
pip3 install mdx_truly_sane_lists
```
##### Directly from git:
```console
pip3 install git+git://github.com/radude/mdx_truly_sane_lists
```
## Usage
Basic:
```python
from markdown import markdown
# Default config is truly_sane: True, nested_indent: 2
markdown(text='some text', extensions=['mdx_truly_sane_lists'])
```
With explicit config:
```python
from markdown import markdown
markdown(text='some text',
extensions=[
'mdx_truly_sane_lists',
],
extension_configs={
'mdx_truly_sane_lists': {
'nested_indent': 2,
'truly_sane': True,
}},
)
```
## Screenshots and examples
You can preview the new behaviour live at [rentry.co](https://rentry.co/) (uses `nested_indent: 2, truly_sane: True`)
Some ugly screenshots because I'm lazy and cannot into gimp:
![](https://i.imgur.com/7l2bWLY.png)
![](https://i.imgur.com/Ruwfb2A.png)
## HTML
Data:
```markdown
- attributes
- customer
- first_name
- family_name
- email
- person
- first_name
- family_name
- birth_date
- subscription_id
- request
```
No extension:
```html before
-
attributes
-
customer
- first_name
- family_name
- email
- person
- first_name
- family_name
- birth_date
-
subscription_id
-
request
```
Truly sane + 4 spaces:
```html
- customer
- first_name
- family_name
- email
- person
- first_name
- family_name
- birth_date
- subscription_id
```
%package help
Summary: Development documents and examples for mdx-truly-sane-lists
Provides: python3-mdx-truly-sane-lists-doc
%description help
# Mdx Truly Sane Lists
[![Build Status](https://travis-ci.org/radude/mdx_truly_sane_lists.svg?branch=master)](https://travis-ci.org/radude/mdx_truly_sane_lists)
An extension for [Python-Markdown](https://github.com/Python-Markdown/markdown) that makes lists truly sane. Features custom indents for nested lists and fix for messy linebreaks and paragraphs between lists.
## Features
* `nested_indent` option: Custom indent for nested lists. Defaults to `2`. Doesn't mess with code indents, which is still 4.
* `truly_sane` option: Makes linebreaks and paragraphs in lists behave as usually expected by user. No longer adds weird `p`, no extra linebreaks, no longer fuses lists together when they shouldn't be fused (see screenshots and examples below). Defaults to `True`.
* Inherits [sane lists](https://python-markdown.github.io/extensions/sane_lists/) behavior, which doesn't allow the mixing of ordered and unordered lists.
## Installation
##### [Pypi](https://pypi.python.org/pypi/mdx-truly-sane-lists):
```console
pip3 install mdx_truly_sane_lists
```
##### Directly from git:
```console
pip3 install git+git://github.com/radude/mdx_truly_sane_lists
```
## Usage
Basic:
```python
from markdown import markdown
# Default config is truly_sane: True, nested_indent: 2
markdown(text='some text', extensions=['mdx_truly_sane_lists'])
```
With explicit config:
```python
from markdown import markdown
markdown(text='some text',
extensions=[
'mdx_truly_sane_lists',
],
extension_configs={
'mdx_truly_sane_lists': {
'nested_indent': 2,
'truly_sane': True,
}},
)
```
## Screenshots and examples
You can preview the new behaviour live at [rentry.co](https://rentry.co/) (uses `nested_indent: 2, truly_sane: True`)
Some ugly screenshots because I'm lazy and cannot into gimp:
![](https://i.imgur.com/7l2bWLY.png)
![](https://i.imgur.com/Ruwfb2A.png)
## HTML
Data:
```markdown
- attributes
- customer
- first_name
- family_name
- email
- person
- first_name
- family_name
- birth_date
- subscription_id
- request
```
No extension:
```html before
-
attributes
-
customer
- first_name
- family_name
- email
- person
- first_name
- family_name
- birth_date
-
subscription_id
-
request
```
Truly sane + 4 spaces:
```html
- customer
- first_name
- family_name
- email
- person
- first_name
- family_name
- birth_date
- subscription_id
```
%prep
%autosetup -n mdx-truly-sane-lists-1.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mdx-truly-sane-lists -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.3-1
- Package Spec generated