%global _empty_manifest_terminate_build 0
Name:		python-gemlog
Version:	1.7.0
Release:	1
Summary:	A set of functions for processing Gem datalogger files.
License:	GPL-3.0
URL:		https://github.com/ajakef/gemlog
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/31/70/253d60f8ecd5b1077beb195b9e518905e60336ae68c4eaf8c8ce1deb16b5/gemlog-1.7.0.tar.gz

Requires:	python3-setuptools
Requires:	python3-obspy
Requires:	python3-numpy
Requires:	python3-pandas
Requires:	python3-scipy
Requires:	python3-matplotlib
Requires:	python3-cython
Requires:	python3-fpdf
Requires:	python3-pytest
Requires:	python3-sphinx-rtd-theme
Requires:	python3-sphinx
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-pytest

%description

gemlog is a python package that provides functions for processing the
log files from the Gem infrasound datalogger. The Gem infrasound logger
is a low-cost, lightweight, low-power instrument for recording infrasound
in field campaigns.

Source code: https://github.com/ajakef/gemlog




%package -n python3-gemlog
Summary:	A set of functions for processing Gem datalogger files.
Provides:	python-gemlog
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-gemlog

gemlog is a python package that provides functions for processing the
log files from the Gem infrasound datalogger. The Gem infrasound logger
is a low-cost, lightweight, low-power instrument for recording infrasound
in field campaigns.

Source code: https://github.com/ajakef/gemlog




%package help
Summary:	Development documents and examples for gemlog
Provides:	python3-gemlog-doc
%description help

gemlog is a python package that provides functions for processing the
log files from the Gem infrasound datalogger. The Gem infrasound logger
is a low-cost, lightweight, low-power instrument for recording infrasound
in field campaigns.

Source code: https://github.com/ajakef/gemlog




%prep
%autosetup -n gemlog-1.7.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-gemlog -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.0-1
- Package Spec generated