%global _empty_manifest_terminate_build 0
Name: python-npTDMS
Version: 1.6.2
Release: 1
Summary: Cross-platform, NumPy based module for reading TDMS files produced by LabView
License: LGPL
URL: https://github.com/adamreeve/npTDMS
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7b/f5/449aeedf4ddb633f8ff390d6b5e0f3cc4f6d77b55527ae82535fd1154e76/npTDMS-1.6.2.tar.gz
BuildArch: noarch
%description
npTDMS is a cross-platform Python package for reading and writing TDMS files as produced by LabVIEW,
and is built on top of the `numpy `__ package.
Data is read from TDMS files as numpy arrays,
and npTDMS also allows writing numpy arrays to TDMS files.
TDMS files are structured in a hierarchy of groups and channels.
A TDMS file can contain multiple groups, which may each contain multiple channels.
A file, group and channel may all have properties associated with them,
but only channels have array data.
Typical usage when reading a TDMS file might look like::
from nptdms import TdmsFile
tdms_file = TdmsFile.read("path_to_file.tdms")
group = tdms_file['group name']
channel = group['channel name']
channel_data = channel[:]
channel_properties = channel.properties
The ``TdmsFile.read`` method reads all data into memory immediately.
When you are working with large TDMS files or don't need to read all channel data,
you can instead use ``TdmsFile.open``. This is more memory efficient but
accessing data can be slower::
with TdmsFile.open("path_to_file.tdms") as tdms_file:
group = tdms_file['group name']
channel = group['channel name']
channel_data = channel[:]
npTDMS also has rudimentary support for writing TDMS files.
Using npTDMS to write a TDMS file looks like::
from nptdms import TdmsWriter, ChannelObject
import numpy
with TdmsWriter("path_to_file.tdms") as tdms_writer:
data_array = numpy.linspace(0, 1, 10)
channel = ChannelObject('group name', 'channel name', data_array)
tdms_writer.write_segment([channel])
For more detailed documentation on reading and writing TDMS files,
see the `npTDMS documentation `__.
%package -n python3-npTDMS
Summary: Cross-platform, NumPy based module for reading TDMS files produced by LabView
Provides: python-npTDMS
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-npTDMS
npTDMS is a cross-platform Python package for reading and writing TDMS files as produced by LabVIEW,
and is built on top of the `numpy `__ package.
Data is read from TDMS files as numpy arrays,
and npTDMS also allows writing numpy arrays to TDMS files.
TDMS files are structured in a hierarchy of groups and channels.
A TDMS file can contain multiple groups, which may each contain multiple channels.
A file, group and channel may all have properties associated with them,
but only channels have array data.
Typical usage when reading a TDMS file might look like::
from nptdms import TdmsFile
tdms_file = TdmsFile.read("path_to_file.tdms")
group = tdms_file['group name']
channel = group['channel name']
channel_data = channel[:]
channel_properties = channel.properties
The ``TdmsFile.read`` method reads all data into memory immediately.
When you are working with large TDMS files or don't need to read all channel data,
you can instead use ``TdmsFile.open``. This is more memory efficient but
accessing data can be slower::
with TdmsFile.open("path_to_file.tdms") as tdms_file:
group = tdms_file['group name']
channel = group['channel name']
channel_data = channel[:]
npTDMS also has rudimentary support for writing TDMS files.
Using npTDMS to write a TDMS file looks like::
from nptdms import TdmsWriter, ChannelObject
import numpy
with TdmsWriter("path_to_file.tdms") as tdms_writer:
data_array = numpy.linspace(0, 1, 10)
channel = ChannelObject('group name', 'channel name', data_array)
tdms_writer.write_segment([channel])
For more detailed documentation on reading and writing TDMS files,
see the `npTDMS documentation `__.
%package help
Summary: Development documents and examples for npTDMS
Provides: python3-npTDMS-doc
%description help
npTDMS is a cross-platform Python package for reading and writing TDMS files as produced by LabVIEW,
and is built on top of the `numpy `__ package.
Data is read from TDMS files as numpy arrays,
and npTDMS also allows writing numpy arrays to TDMS files.
TDMS files are structured in a hierarchy of groups and channels.
A TDMS file can contain multiple groups, which may each contain multiple channels.
A file, group and channel may all have properties associated with them,
but only channels have array data.
Typical usage when reading a TDMS file might look like::
from nptdms import TdmsFile
tdms_file = TdmsFile.read("path_to_file.tdms")
group = tdms_file['group name']
channel = group['channel name']
channel_data = channel[:]
channel_properties = channel.properties
The ``TdmsFile.read`` method reads all data into memory immediately.
When you are working with large TDMS files or don't need to read all channel data,
you can instead use ``TdmsFile.open``. This is more memory efficient but
accessing data can be slower::
with TdmsFile.open("path_to_file.tdms") as tdms_file:
group = tdms_file['group name']
channel = group['channel name']
channel_data = channel[:]
npTDMS also has rudimentary support for writing TDMS files.
Using npTDMS to write a TDMS file looks like::
from nptdms import TdmsWriter, ChannelObject
import numpy
with TdmsWriter("path_to_file.tdms") as tdms_writer:
data_array = numpy.linspace(0, 1, 10)
channel = ChannelObject('group name', 'channel name', data_array)
tdms_writer.write_segment([channel])
For more detailed documentation on reading and writing TDMS files,
see the `npTDMS documentation `__.
%prep
%autosetup -n npTDMS-1.6.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-npTDMS -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.6.2-1
- Package Spec generated