%global _empty_manifest_terminate_build 0
Name:		python-django-pgconnection
Version:	1.0.3
Release:	1
Summary:	Route postgres connections and hook into cursor execution
License:	BSD-3-Clause
URL:		https://github.com/Opus10/django-pgconnection
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4f/fa/507cc09eedca06e0e37dc27f77be1e19ddc2f087d3c05b0b8ded8cebc62f/django-pgconnection-1.0.3.tar.gz
BuildArch:	noarch

Requires:	python3-django
Requires:	python3-importlib_metadata

%description
`View the django-pgconnection docs here
<https://django-pgconnection.readthedocs.io/>`_.

%package -n python3-django-pgconnection
Summary:	Route postgres connections and hook into cursor execution
Provides:	python-django-pgconnection
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-pgconnection
`View the django-pgconnection docs here
<https://django-pgconnection.readthedocs.io/>`_.

%package help
Summary:	Development documents and examples for django-pgconnection
Provides:	python3-django-pgconnection-doc
%description help
`View the django-pgconnection docs here
<https://django-pgconnection.readthedocs.io/>`_.

%prep
%autosetup -n django-pgconnection-1.0.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-pgconnection -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.3-1
- Package Spec generated