%global _empty_manifest_terminate_build 0 Name: python-imgviz Version: 1.7.2 Release: 1 Summary: Image Visualization Tools License: MIT URL: http://github.com/wkentaro/imgviz Source0: https://mirrors.nju.edu.cn/pypi/web/packages/af/35/3c7ecc8bc21213ca5a92aead94c79a65018e1be5a26ba4589dda2f3b5b56/imgviz-1.7.2.tar.gz BuildArch: noarch Requires: python3-matplotlib Requires: python3-numpy Requires: python3-Pillow Requires: python3-PyYAML Requires: python3-scikit-image Requires: python3-scikit-learn Requires: python3-opencv-python Requires: python3-pyglet %description

imgviz

Image Visualization Tools

Documentation Status
Documentation | Installation | Getting Started | Examples | C++ Version

## Installation ```bash pip install imgviz # there are optional dependencies like skimage, below installs all. pip install imgviz[all] ``` ## Dependencies - [matplotlib](https://pypi.org/project/matplotlib) - [numpy](https://pypi.org/project/numpy) - [Pillow>=5.3.0](https://pypi.org/project/Pillow) - [PyYAML](https://pypi.org/project/PyYAML) ## Getting Started ```python # getting_started.py import imgviz # sample data of rgb, depth, class label and instance masks data = imgviz.data.arc2017() rgb = data["rgb"] gray = imgviz.rgb2gray(rgb) # colorize depth image with JET colormap depth = data["depth"] depthviz = imgviz.depth2rgb(depth, min_value=0.3, max_value=1) # colorize label image class_label = data["class_label"] labelviz = imgviz.label2rgb(class_label, image=gray, label_names=data["class_names"], font_size=20) # instance bboxes bboxes = data["bboxes"].astype(int) labels = data["labels"] masks = data["masks"] == 1 captions = [data["class_names"][l] for l in labels] maskviz = imgviz.instances2rgb(gray, masks=masks, labels=labels, captions=captions) # tile instance masks insviz = [(rgb * m[:, :, None])[b[0] : b[2], b[1] : b[3]] for b, m in zip(bboxes, masks)] insviz = imgviz.tile(imgs=insviz, border=(255, 255, 255)) insviz = imgviz.resize(insviz, height=rgb.shape[0]) # tile visualization tiled = imgviz.tile( [rgb, depthviz, labelviz, maskviz, insviz], shape=(1, 5), border=(255, 255, 255), border_width=5, ) ``` ## [Examples](examples)
examples/centerize.py
examples/depth2rgb.py
examples/draw.py
examples/flow2rgb.py
examples/instances2rgb.py
examples/label2rgb.py
examples/nchannel2rgb.py
examples/plot_trajectory.py
examples/resize.py
examples/tile.py
%package -n python3-imgviz Summary: Image Visualization Tools Provides: python-imgviz BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-imgviz

imgviz

Image Visualization Tools

Documentation Status
Documentation | Installation | Getting Started | Examples | C++ Version

## Installation ```bash pip install imgviz # there are optional dependencies like skimage, below installs all. pip install imgviz[all] ``` ## Dependencies - [matplotlib](https://pypi.org/project/matplotlib) - [numpy](https://pypi.org/project/numpy) - [Pillow>=5.3.0](https://pypi.org/project/Pillow) - [PyYAML](https://pypi.org/project/PyYAML) ## Getting Started ```python # getting_started.py import imgviz # sample data of rgb, depth, class label and instance masks data = imgviz.data.arc2017() rgb = data["rgb"] gray = imgviz.rgb2gray(rgb) # colorize depth image with JET colormap depth = data["depth"] depthviz = imgviz.depth2rgb(depth, min_value=0.3, max_value=1) # colorize label image class_label = data["class_label"] labelviz = imgviz.label2rgb(class_label, image=gray, label_names=data["class_names"], font_size=20) # instance bboxes bboxes = data["bboxes"].astype(int) labels = data["labels"] masks = data["masks"] == 1 captions = [data["class_names"][l] for l in labels] maskviz = imgviz.instances2rgb(gray, masks=masks, labels=labels, captions=captions) # tile instance masks insviz = [(rgb * m[:, :, None])[b[0] : b[2], b[1] : b[3]] for b, m in zip(bboxes, masks)] insviz = imgviz.tile(imgs=insviz, border=(255, 255, 255)) insviz = imgviz.resize(insviz, height=rgb.shape[0]) # tile visualization tiled = imgviz.tile( [rgb, depthviz, labelviz, maskviz, insviz], shape=(1, 5), border=(255, 255, 255), border_width=5, ) ``` ## [Examples](examples)
examples/centerize.py
examples/depth2rgb.py
examples/draw.py
examples/flow2rgb.py
examples/instances2rgb.py
examples/label2rgb.py
examples/nchannel2rgb.py
examples/plot_trajectory.py
examples/resize.py
examples/tile.py
%package help Summary: Development documents and examples for imgviz Provides: python3-imgviz-doc %description help

imgviz

Image Visualization Tools

Documentation Status
Documentation | Installation | Getting Started | Examples | C++ Version

## Installation ```bash pip install imgviz # there are optional dependencies like skimage, below installs all. pip install imgviz[all] ``` ## Dependencies - [matplotlib](https://pypi.org/project/matplotlib) - [numpy](https://pypi.org/project/numpy) - [Pillow>=5.3.0](https://pypi.org/project/Pillow) - [PyYAML](https://pypi.org/project/PyYAML) ## Getting Started ```python # getting_started.py import imgviz # sample data of rgb, depth, class label and instance masks data = imgviz.data.arc2017() rgb = data["rgb"] gray = imgviz.rgb2gray(rgb) # colorize depth image with JET colormap depth = data["depth"] depthviz = imgviz.depth2rgb(depth, min_value=0.3, max_value=1) # colorize label image class_label = data["class_label"] labelviz = imgviz.label2rgb(class_label, image=gray, label_names=data["class_names"], font_size=20) # instance bboxes bboxes = data["bboxes"].astype(int) labels = data["labels"] masks = data["masks"] == 1 captions = [data["class_names"][l] for l in labels] maskviz = imgviz.instances2rgb(gray, masks=masks, labels=labels, captions=captions) # tile instance masks insviz = [(rgb * m[:, :, None])[b[0] : b[2], b[1] : b[3]] for b, m in zip(bboxes, masks)] insviz = imgviz.tile(imgs=insviz, border=(255, 255, 255)) insviz = imgviz.resize(insviz, height=rgb.shape[0]) # tile visualization tiled = imgviz.tile( [rgb, depthviz, labelviz, maskviz, insviz], shape=(1, 5), border=(255, 255, 255), border_width=5, ) ``` ## [Examples](examples)
examples/centerize.py
examples/depth2rgb.py
examples/draw.py
examples/flow2rgb.py
examples/instances2rgb.py
examples/label2rgb.py
examples/nchannel2rgb.py
examples/plot_trajectory.py
examples/resize.py
examples/tile.py
%prep %autosetup -n imgviz-1.7.2 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-imgviz -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Sun Apr 23 2023 Python_Bot - 1.7.2-1 - Package Spec generated