%global _empty_manifest_terminate_build 0
Name: python-cybox
Version: 2.1.0.21
Release: 1
Summary: A Python library for parsing and generating CybOX content.
License: BSD
URL: https://cyboxproject.github.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/16/67/19479c7e065a50795a957f7f6a29eaf4c94fb3910241c9760869a63f8090/cybox-2.1.0.21.tar.gz
BuildArch: noarch
Requires: python3-mixbox
Requires: python3-dateutil
Requires: python3-lxml
Requires: python3-lxml
%description
A Python library for parsing, manipulating, and generating `Cyber Observable eXpression (CybOX™) `_ v2.1.0 content.
|travis_badge| |landscape_io_badge| |version_badge|
%package -n python3-cybox
Summary: A Python library for parsing and generating CybOX content.
Provides: python-cybox
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cybox
A Python library for parsing, manipulating, and generating `Cyber Observable eXpression (CybOX™) `_ v2.1.0 content.
|travis_badge| |landscape_io_badge| |version_badge|
%package help
Summary: Development documents and examples for cybox
Provides: python3-cybox-doc
%description help
A Python library for parsing, manipulating, and generating `Cyber Observable eXpression (CybOX™) `_ v2.1.0 content.
|travis_badge| |landscape_io_badge| |version_badge|
%prep
%autosetup -n cybox-2.1.0.21
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cybox -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 2.1.0.21-1
- Package Spec generated