%global _empty_manifest_terminate_build 0
Name: python-bleach-allowlist
Version: 1.0.3
Release: 1
Summary: Curated lists of tags and attributes for sanitizing html
License: BSD License
URL: https://github.com/yourcelf/bleach-allowlist.git
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/04/6d/039eca1770f7667d0967d299a1e6d47ad88acde03fcd2076a11e57ff51b4/bleach-allowlist-1.0.3.tar.gz
BuildArch: noarch
%description
A curated list of tags, attributes, and styles suitable for filtering
user-provided HTML using `bleach `_.
Currently, it consists of basic set of tags suitable for rendering markdown,
and markup intended for printing, as well as a list of all CSS styles. Please
send pull requests with improvements or lists of tags and attributes for other
purposes (wikis, comments, etc?).
%package -n python3-bleach-allowlist
Summary: Curated lists of tags and attributes for sanitizing html
Provides: python-bleach-allowlist
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bleach-allowlist
A curated list of tags, attributes, and styles suitable for filtering
user-provided HTML using `bleach `_.
Currently, it consists of basic set of tags suitable for rendering markdown,
and markup intended for printing, as well as a list of all CSS styles. Please
send pull requests with improvements or lists of tags and attributes for other
purposes (wikis, comments, etc?).
%package help
Summary: Development documents and examples for bleach-allowlist
Provides: python3-bleach-allowlist-doc
%description help
A curated list of tags, attributes, and styles suitable for filtering
user-provided HTML using `bleach `_.
Currently, it consists of basic set of tags suitable for rendering markdown,
and markup intended for printing, as well as a list of all CSS styles. Please
send pull requests with improvements or lists of tags and attributes for other
purposes (wikis, comments, etc?).
%prep
%autosetup -n bleach-allowlist-1.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-bleach-allowlist -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 1.0.3-1
- Package Spec generated