%global _empty_manifest_terminate_build 0
Name: python-search-google
Version: 1.2.1
Release: 1
Summary: A command line tool and module for Google API web and image search.
License: MIT
URL: https://github.com/rrwen/search_google
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/78/2d/479a767d29e1007b81c8007c2effc92f08548971797ffaf944a72e78f32b/search_google-1.2.1.tar.gz
BuildArch: noarch
%description
1. Install `Python `_
2. Install `search_google `_ via ``pip``
pip install search_google
For the latest developer version, see `Developer Install`_.
%package -n python3-search-google
Summary: A command line tool and module for Google API web and image search.
Provides: python-search-google
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-search-google
1. Install `Python `_
2. Install `search_google `_ via ``pip``
pip install search_google
For the latest developer version, see `Developer Install`_.
%package help
Summary: Development documents and examples for search-google
Provides: python3-search-google-doc
%description help
1. Install `Python `_
2. Install `search_google `_ via ``pip``
pip install search_google
For the latest developer version, see `Developer Install`_.
%prep
%autosetup -n search-google-1.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-search-google -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 1.2.1-1
- Package Spec generated