%global _empty_manifest_terminate_build 0
Name:		python-UCCA
Version:	1.3.11
Release:	1
Summary:	Universal Conceptual Cognitive Annotation
License:	GNU General Public License v3 or later (GPLv3+)
URL:		https://github.com/huji-nlp/ucca
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4c/a5/a42028dcc21c3d1ddaf609daa57863362bc88bff7072b5c96550aa06ca5f/UCCA-1.3.11.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-spacy
Requires:	python3-requests
Requires:	python3-tqdm
Requires:	python3-distances
Requires:	python3-zss
Requires:	python3-munkres
Requires:	python3-matplotlib
Requires:	python3-networkx

%description
UCCA is a linguistic framework for semantic annotation, whose details
are available at [the following paper](http://aclweb.org/anthology/P13-1023):
    @inproceedings{abend2013universal,
      author={Abend, Omri  and  Rappoport, Ari},
      title={{U}niversal {C}onceptual {C}ognitive {A}nnotation ({UCCA})},
      booktitle={Proc. of ACL},
      month={August},
      year={2013},
      pages={228--238},
      url={http://aclweb.org/anthology/P13-1023}
    }
This Python 3 package provides an API to the UCCA annotation and tools to
manipulate and process it. Its main features are conversion between different
representations of UCCA annotations, and rich objects for all of the linguistic
relations which appear in the theoretical framework (see `core`, `layer0`, `layer1`
and `convert` modules under the `ucca` package).
The `scripts` package contains various utilities for processing passage files.
To parse text to UCCA graphs, use [TUPA, the UCCA parser](https://github.com/danielhers/tupa).

%package -n python3-UCCA
Summary:	Universal Conceptual Cognitive Annotation
Provides:	python-UCCA
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-UCCA
UCCA is a linguistic framework for semantic annotation, whose details
are available at [the following paper](http://aclweb.org/anthology/P13-1023):
    @inproceedings{abend2013universal,
      author={Abend, Omri  and  Rappoport, Ari},
      title={{U}niversal {C}onceptual {C}ognitive {A}nnotation ({UCCA})},
      booktitle={Proc. of ACL},
      month={August},
      year={2013},
      pages={228--238},
      url={http://aclweb.org/anthology/P13-1023}
    }
This Python 3 package provides an API to the UCCA annotation and tools to
manipulate and process it. Its main features are conversion between different
representations of UCCA annotations, and rich objects for all of the linguistic
relations which appear in the theoretical framework (see `core`, `layer0`, `layer1`
and `convert` modules under the `ucca` package).
The `scripts` package contains various utilities for processing passage files.
To parse text to UCCA graphs, use [TUPA, the UCCA parser](https://github.com/danielhers/tupa).

%package help
Summary:	Development documents and examples for UCCA
Provides:	python3-UCCA-doc
%description help
UCCA is a linguistic framework for semantic annotation, whose details
are available at [the following paper](http://aclweb.org/anthology/P13-1023):
    @inproceedings{abend2013universal,
      author={Abend, Omri  and  Rappoport, Ari},
      title={{U}niversal {C}onceptual {C}ognitive {A}nnotation ({UCCA})},
      booktitle={Proc. of ACL},
      month={August},
      year={2013},
      pages={228--238},
      url={http://aclweb.org/anthology/P13-1023}
    }
This Python 3 package provides an API to the UCCA annotation and tools to
manipulate and process it. Its main features are conversion between different
representations of UCCA annotations, and rich objects for all of the linguistic
relations which appear in the theoretical framework (see `core`, `layer0`, `layer1`
and `convert` modules under the `ucca` package).
The `scripts` package contains various utilities for processing passage files.
To parse text to UCCA graphs, use [TUPA, the UCCA parser](https://github.com/danielhers/tupa).

%prep
%autosetup -n UCCA-1.3.11

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-UCCA -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.11-1
- Package Spec generated