%global _empty_manifest_terminate_build 0
Name: python-xkcd
Version: 2.4.2
Release: 1
Summary: Library to access xkcd.com
License: MIT
URL: https://github.com/TC01/python-xkcd
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f8/dc/8e9824517b9fbc42f6d95a1a5d345c6b9e6dd885ec3a301953ac7c2fb4d3/xkcd-2.4.2.tar.gz
BuildArch: noarch
%description
A Python interface to xkcd.com
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
By Ben Rosser, released under MIT License (see LICENSE for full text).
This is a Python library for accessing and retrieving links to comics
from the xkcd webcomic by Randall Munroe. It is NOT endorsed or made by
him, it's an entirely independent project.
It makes use of the JSON interface to Randall's site to retrieve comic
data. Both Python 2 and Python 3 are supported, and there are no
dependencies beyond the Python standard library, so xkcd's footprint
should be very light.
There is support for accessing specific comics, the latest comic, or a
random comic. Comic metadata can be queried and the comics themselves
can be downloaded onto your local system. The goal is simply to provide
a relatively Pythonic wrapper around the xkcd API for any Python program
or library that wants to access information about xkcd comics, for one
reason or another.
The xkcd module, as of version 2.4.0, also supports getting information
on What If articles from whatif.xkcd.com. This information is generated
by scraping the What If archive page with a HTML parser.
Full API documentation is available
`here `__.
%package -n python3-xkcd
Summary: Library to access xkcd.com
Provides: python-xkcd
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-xkcd
A Python interface to xkcd.com
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
By Ben Rosser, released under MIT License (see LICENSE for full text).
This is a Python library for accessing and retrieving links to comics
from the xkcd webcomic by Randall Munroe. It is NOT endorsed or made by
him, it's an entirely independent project.
It makes use of the JSON interface to Randall's site to retrieve comic
data. Both Python 2 and Python 3 are supported, and there are no
dependencies beyond the Python standard library, so xkcd's footprint
should be very light.
There is support for accessing specific comics, the latest comic, or a
random comic. Comic metadata can be queried and the comics themselves
can be downloaded onto your local system. The goal is simply to provide
a relatively Pythonic wrapper around the xkcd API for any Python program
or library that wants to access information about xkcd comics, for one
reason or another.
The xkcd module, as of version 2.4.0, also supports getting information
on What If articles from whatif.xkcd.com. This information is generated
by scraping the What If archive page with a HTML parser.
Full API documentation is available
`here `__.
%package help
Summary: Development documents and examples for xkcd
Provides: python3-xkcd-doc
%description help
A Python interface to xkcd.com
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
By Ben Rosser, released under MIT License (see LICENSE for full text).
This is a Python library for accessing and retrieving links to comics
from the xkcd webcomic by Randall Munroe. It is NOT endorsed or made by
him, it's an entirely independent project.
It makes use of the JSON interface to Randall's site to retrieve comic
data. Both Python 2 and Python 3 are supported, and there are no
dependencies beyond the Python standard library, so xkcd's footprint
should be very light.
There is support for accessing specific comics, the latest comic, or a
random comic. Comic metadata can be queried and the comics themselves
can be downloaded onto your local system. The goal is simply to provide
a relatively Pythonic wrapper around the xkcd API for any Python program
or library that wants to access information about xkcd comics, for one
reason or another.
The xkcd module, as of version 2.4.0, also supports getting information
on What If articles from whatif.xkcd.com. This information is generated
by scraping the What If archive page with a HTML parser.
Full API documentation is available
`here `__.
%prep
%autosetup -n xkcd-2.4.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-xkcd -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 2.4.2-1
- Package Spec generated