%global _empty_manifest_terminate_build 0
Name:		python-dame-flame
Version:	0.51
Release:	1
Summary:	Causal Inference Covariate Matching
License:	MIT
URL:		https://github.com/almost-matching-exactly/DAME-FLAME-Python-Package
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/03/fb/a83870884fb83be6f2dfa3b28b6b5be475f913e01b91d4fc247853c64799/dame_flame-0.51.tar.gz
BuildArch:	noarch

Requires:	python3-scikit-learn
Requires:	python3-scipy
Requires:	python3-pandas
Requires:	python3-numpy

%description
## Documentation [here](https://almost-matching-exactly.github.io/DAME-FLAME-Python-Package/)
DAME-FLAME is a Python package for performing matching for observational causal inference on datasets containing discrete covariates. It implements the Dynamic Almost Matching Exactly (DAME) and Fast, Large-Scale Almost Matching Exactly (FLAME) algorithms, which match treatment and control units on subsets of the covariates. The resulting matched groups are interpretable, because the matches are made on covariates, and high-quality, because machine learning is used to determine which covariates are important to match on.
### Installation
#### Dependencies
`dame-flame` requires Python version (>=3.6.5). Install from [here](https://www.python.org/downloads/) if needed.
- pandas>=0.11.0
- numpy>= 1.16.5
- scikit-learn>=0.23.2
If your python version does not have these packages, install from [here](https://packaging.python.org/tutorials/installing-packages/).
To run the examples in the examples folder (these are not part of the package), Jupyter Notebooks or Jupyter Lab (available [here](https://jupyter.org/install)) and Matplotlib (>=2.0.0) is also required.
#### User Installation
Download from PyPi via
$ pip install dame-flame

%package -n python3-dame-flame
Summary:	Causal Inference Covariate Matching
Provides:	python-dame-flame
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-dame-flame
## Documentation [here](https://almost-matching-exactly.github.io/DAME-FLAME-Python-Package/)
DAME-FLAME is a Python package for performing matching for observational causal inference on datasets containing discrete covariates. It implements the Dynamic Almost Matching Exactly (DAME) and Fast, Large-Scale Almost Matching Exactly (FLAME) algorithms, which match treatment and control units on subsets of the covariates. The resulting matched groups are interpretable, because the matches are made on covariates, and high-quality, because machine learning is used to determine which covariates are important to match on.
### Installation
#### Dependencies
`dame-flame` requires Python version (>=3.6.5). Install from [here](https://www.python.org/downloads/) if needed.
- pandas>=0.11.0
- numpy>= 1.16.5
- scikit-learn>=0.23.2
If your python version does not have these packages, install from [here](https://packaging.python.org/tutorials/installing-packages/).
To run the examples in the examples folder (these are not part of the package), Jupyter Notebooks or Jupyter Lab (available [here](https://jupyter.org/install)) and Matplotlib (>=2.0.0) is also required.
#### User Installation
Download from PyPi via
$ pip install dame-flame

%package help
Summary:	Development documents and examples for dame-flame
Provides:	python3-dame-flame-doc
%description help
## Documentation [here](https://almost-matching-exactly.github.io/DAME-FLAME-Python-Package/)
DAME-FLAME is a Python package for performing matching for observational causal inference on datasets containing discrete covariates. It implements the Dynamic Almost Matching Exactly (DAME) and Fast, Large-Scale Almost Matching Exactly (FLAME) algorithms, which match treatment and control units on subsets of the covariates. The resulting matched groups are interpretable, because the matches are made on covariates, and high-quality, because machine learning is used to determine which covariates are important to match on.
### Installation
#### Dependencies
`dame-flame` requires Python version (>=3.6.5). Install from [here](https://www.python.org/downloads/) if needed.
- pandas>=0.11.0
- numpy>= 1.16.5
- scikit-learn>=0.23.2
If your python version does not have these packages, install from [here](https://packaging.python.org/tutorials/installing-packages/).
To run the examples in the examples folder (these are not part of the package), Jupyter Notebooks or Jupyter Lab (available [here](https://jupyter.org/install)) and Matplotlib (>=2.0.0) is also required.
#### User Installation
Download from PyPi via
$ pip install dame-flame

%prep
%autosetup -n dame-flame-0.51

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-dame-flame -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.51-1
- Package Spec generated