%global _empty_manifest_terminate_build 0
Name: python-FireWorks
Version: 2.0.3
Release: 1
Summary: FireWorks workflow software
License: modified BSD
URL: https://github.com/materialsproject/fireworks
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d1/9a/54d72f7b09995155f513064d1e6207b3ac87f73306b4c0522c3dd68b6a57/FireWorks-2.0.3.tar.gz
BuildArch: noarch
%description
#
FireWorks stores, executes, and manages calculation workflows.
- **Website (including documentation):** https://materialsproject.github.io/fireworks/
- **Help/Support:** https://discuss.matsci.org/c/fireworks
- **Source:** https://github.com/materialsproject/fireworks/
If you like FireWorks, you might also like [rocketsled](https://github.com/hackingmaterials/rocketsled).
If you find FireWorks useful, please consider citing the paper:
```
Jain, A., Ong, S. P., Chen, W., Medasani, B., Qu, X., Kocher, M., Brafman, M.,
Petretto, G., Rignanese, G.-M., Hautier, G., Gunter, D., and Persson, K. A.
(2015) FireWorks: a dynamic workflow system designed for high-throughput
applications. Concurrency Computat.: Pract. Exper., 27: 5037–5059.
doi: 10.1002/cpe.3505.
```
%package -n python3-FireWorks
Summary: FireWorks workflow software
Provides: python-FireWorks
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-FireWorks
#
FireWorks stores, executes, and manages calculation workflows.
- **Website (including documentation):** https://materialsproject.github.io/fireworks/
- **Help/Support:** https://discuss.matsci.org/c/fireworks
- **Source:** https://github.com/materialsproject/fireworks/
If you like FireWorks, you might also like [rocketsled](https://github.com/hackingmaterials/rocketsled).
If you find FireWorks useful, please consider citing the paper:
```
Jain, A., Ong, S. P., Chen, W., Medasani, B., Qu, X., Kocher, M., Brafman, M.,
Petretto, G., Rignanese, G.-M., Hautier, G., Gunter, D., and Persson, K. A.
(2015) FireWorks: a dynamic workflow system designed for high-throughput
applications. Concurrency Computat.: Pract. Exper., 27: 5037–5059.
doi: 10.1002/cpe.3505.
```
%package help
Summary: Development documents and examples for FireWorks
Provides: python3-FireWorks-doc
%description help
#
FireWorks stores, executes, and manages calculation workflows.
- **Website (including documentation):** https://materialsproject.github.io/fireworks/
- **Help/Support:** https://discuss.matsci.org/c/fireworks
- **Source:** https://github.com/materialsproject/fireworks/
If you like FireWorks, you might also like [rocketsled](https://github.com/hackingmaterials/rocketsled).
If you find FireWorks useful, please consider citing the paper:
```
Jain, A., Ong, S. P., Chen, W., Medasani, B., Qu, X., Kocher, M., Brafman, M.,
Petretto, G., Rignanese, G.-M., Hautier, G., Gunter, D., and Persson, K. A.
(2015) FireWorks: a dynamic workflow system designed for high-throughput
applications. Concurrency Computat.: Pract. Exper., 27: 5037–5059.
doi: 10.1002/cpe.3505.
```
%prep
%autosetup -n FireWorks-2.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-FireWorks -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 2.0.3-1
- Package Spec generated