%global _empty_manifest_terminate_build 0
Name: python-AoE2ScenarioParser
Version: 0.1.53
Release: 1
Summary: This is a project for editing parts of an 'aoe2scenario' file from Age of Empires 2 Definitive Edition
License: GNU General Public License v3 (GPLv3)
URL: https://github.com/KSneijders/AoE2ScenarioParser
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6f/19/06a7a66f95f64a2b9b46529c0eebc158f088697900b8b5b6d432ec7d8490/AoE2ScenarioParser-0.1.53.tar.gz
BuildArch: noarch
Requires: python3-deprecation
Requires: python3-typing-extensions
Requires: python3-ordered-set
%description
# AoE2ScenarioParser
This is a project for editing parts of an `aoe2scenario` file from **Age of Empires 2 Definitive Edition** outside
the in-game editor.
# Getting started
[GitHub Pages]: https://ksneijders.github.io/AoE2ScenarioParser/
## Quick links
- [Installing AoE2ScenarioParser](https://ksneijders.github.io/AoE2ScenarioParser/installation/)
- [Getting Started](https://ksneijders.github.io/AoE2ScenarioParser/getting_started/)
- [Hello World Example](https://ksneijders.github.io/AoE2ScenarioParser/hello_world/)
- [Discord Server](https://discord.gg/DRUtmugXT3)
- [API Docs](https://ksneijders.github.io/AoE2ScenarioParser/api_docs/aoe2_scenario/)
## Documentation
Documentation can be found on **[GitHub Pages]**.
# Discord
If you have any questions regarding the parser, [join the discord]!
[join the discord]: https://discord.gg/DRUtmugXT3
# Progress
Current up-to-date progress can be found on the [changelog.md] page. (Check the `dev` branch for non-released progress).
[changelog.md]: https://github.com/KSneijders/AoE2ScenarioParser/blob/dev/CHANGELOG.md
## Features:
| | View | Add | Edit | Remove |
|------------|--------------------|---------------------|--------------------|---------------------|
| Triggers | ✔️ | ✔️ | ✔️ | ✔️ |
| Conditions | ✔️ | ✔️ | ✔️ | ✔️ |
| Effects | ✔️ | ✔️ | ✔️ | ✔️ |
| Units | n/a *1 | ✔️ | ✔️ | ✔️ |
| Map | n/a *1 | ✔️ | ✔️ | ✔️ |
| Players | n/a *1 | ✔️* | ✔️ | ✔️* |
*: You can disable or enable players like in the in-game editor (min 1, max 8).
*1: There's no overall formatting function to display these. Though, they can still be printed.
## Support:
| Scenario file version | Read | Write | Reference |
|-----------------------|--------------------|--------------------|-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| 1.36 | ✔️ | ✔️ | Version since the**release of the Definitive Edition** |
| 1.37 | ✔️ | ✔️ | Version since game update: [35584] (February 27th, 2020)
**Unchanged in**:
- Update [36202] (March 30th, 2020)
- Update [36906] (April 29th, 2020)
- Update [37650] (May 27th, 2020)
- Hotfix [37906] (June 2nd, 2020)
- Update [39284] (July 20th, 2020)
- Hotfix [39515] (July 27th, 2020)
- Update [40220] (August 24th, 2020)
- Update [40874] (September 22nd, 2020)
- Update [41855] (October 20th, 2020) |
| 1.40 | ✔️ | ✔️ | Version since game update: [42848] (November 17th, 2020)
**Unchanged in**:
- Hotfix [43210] (November 24th, 2020) |
| 1.41 | ✔️ | ✔️ | Version since game update: [44725] (January 25th, 2021)
**Unchanged in**:
- Hotfix [44834] (January 28th, 2021)
- Hotfix [45185] (February 11th, 2021)
- Update [46265] (March 24th, 2021)
- Update [47820] (May 3rd, 2021) |
| 1.42 | ✔️ | ✔️ | Version since game update: [50292] (July 6th, 2021)
**Unchanged in**:
- Hotfix [50700] (July 13th, 2021) |
| 1.43 | ✔️ | ✔️ | Version since game update: [51737] (August 10th, 2021) |
| 1.44 | ✔️ | ✔️ | Version since game update: [54480] (October 5th, 2021)
**Unchanged in**:
- Hotfix [54684] (October 6th, 2021) |
| 1.45 | ✔️ | ✔️ | Version since game update: [56005] (November 17th, 2021)
**Unchanged in**:
- Update [58259] (January 31st, 2022) |
| 1.46 | ✔️ | ✔️ | Version since game update: [61321] (April 27th, 2022)
**Unchanged in**:
- Update [63482] (June 28th, 2021)
- Hotfix [63581] (July 6th, 2021) |
| 1.47 | ✔️ | ✔️ | Version since game update: [66692] (August 29th, 2022)
**Unchanged in**:
- Update [73855] (December 7th, 2022)
- Update 75350 (Console update) (January 31st, 2023)
- Update [78174] (March 8th, 2023)
- Hotfix [78757] (March 8th, 2023) |
| 1.48 | ✔️ | ✔️ | Version since game update: 79888 (apr_pup 2023) (March 25th, 2023) |
[35584]: https://www.ageofempires.com/news/aoe2de-update-35584/
[36202]: https://www.ageofempires.com/news/aoe2de-update-36202/
[36906]: https://www.ageofempires.com/news/aoe2de-update-36906/
[37650]: https://www.ageofempires.com/news/aoe2de-update-37650/
[37906]: https://www.ageofempires.com/news/aoe2de-hotfix-37906/
[39284]: https://www.ageofempires.com/news/aoe2de-update-39284/
[39515]: https://www.ageofempires.com/news/aoe2de-hotfix-39515/
[40220]: https://www.ageofempires.com/news/aoe2de-update-40220/
[40874]: https://www.ageofempires.com/news/aoe2de-update-40874/
[41855]: https://www.ageofempires.com/news/aoe2de-update-41855/
[42848]: https://www.ageofempires.com/news/aoe2de-update-42848/
[43210]: https://www.ageofempires.com/news/aoe2de-hotfix-43210/
[44725]: https://www.ageofempires.com/news/aoeiide-update-44725/
[44834]: https://www.ageofempires.com/news/aoeiide-update-44725/#hotfix-44834
[45185]: https://www.ageofempires.com/news/aoe2de-hotfix-45185/
[46265]: https://www.ageofempires.com/news/aoe2de-update-46295/
[47820]: https://www.ageofempires.com/news/aoe2de-update-47820/
[50292]: https://www.ageofempires.com/news/aoe2de-update-50292/
[50700]: https://www.ageofempires.com/news/aoe2de-update-50292/#hotfix-50700
[51737]: https://www.ageofempires.com/news/aoeiide-update-51737/
[54480]: https://www.ageofempires.com/news/aoeii-de-update-54480/
[54684]: https://www.ageofempires.com/news/aoeii-de-update-54480/#hotfix-54684
[56005]: https://www.ageofempires.com/news/aoeii_de_update_56005/
[58259]: https://www.ageofempires.com/news/aoe-ii-de-update-58259/
[61321]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-61321/
[63482]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-63482/
[63581]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-63482#Hotfix-63581
[66692]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-66692/
[73855]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-73855/
[78174]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-78174/
[78757]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-78174#641ecbac39a80
# Authors
- Kerwin Sneijders (Main Author)
- [Alian713](https://github.com/Divy1211) (Dataset Wizard)
# License
MIT License: Please see the [LICENSE file].
[license file]: https://github.com/KSneijders/AoE2ScenarioParser/blob/dev/LICENSE
%package -n python3-AoE2ScenarioParser
Summary: This is a project for editing parts of an 'aoe2scenario' file from Age of Empires 2 Definitive Edition
Provides: python-AoE2ScenarioParser
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-AoE2ScenarioParser
# AoE2ScenarioParser
This is a project for editing parts of an `aoe2scenario` file from **Age of Empires 2 Definitive Edition** outside
the in-game editor.
# Getting started
[GitHub Pages]: https://ksneijders.github.io/AoE2ScenarioParser/
## Quick links
- [Installing AoE2ScenarioParser](https://ksneijders.github.io/AoE2ScenarioParser/installation/)
- [Getting Started](https://ksneijders.github.io/AoE2ScenarioParser/getting_started/)
- [Hello World Example](https://ksneijders.github.io/AoE2ScenarioParser/hello_world/)
- [Discord Server](https://discord.gg/DRUtmugXT3)
- [API Docs](https://ksneijders.github.io/AoE2ScenarioParser/api_docs/aoe2_scenario/)
## Documentation
Documentation can be found on **[GitHub Pages]**.
# Discord
If you have any questions regarding the parser, [join the discord]!
[join the discord]: https://discord.gg/DRUtmugXT3
# Progress
Current up-to-date progress can be found on the [changelog.md] page. (Check the `dev` branch for non-released progress).
[changelog.md]: https://github.com/KSneijders/AoE2ScenarioParser/blob/dev/CHANGELOG.md
## Features:
| | View | Add | Edit | Remove |
|------------|--------------------|---------------------|--------------------|---------------------|
| Triggers | ✔️ | ✔️ | ✔️ | ✔️ |
| Conditions | ✔️ | ✔️ | ✔️ | ✔️ |
| Effects | ✔️ | ✔️ | ✔️ | ✔️ |
| Units | n/a *1 | ✔️ | ✔️ | ✔️ |
| Map | n/a *1 | ✔️ | ✔️ | ✔️ |
| Players | n/a *1 | ✔️* | ✔️ | ✔️* |
*: You can disable or enable players like in the in-game editor (min 1, max 8).
*1: There's no overall formatting function to display these. Though, they can still be printed.
## Support:
| Scenario file version | Read | Write | Reference |
|-----------------------|--------------------|--------------------|-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| 1.36 | ✔️ | ✔️ | Version since the**release of the Definitive Edition** |
| 1.37 | ✔️ | ✔️ | Version since game update: [35584] (February 27th, 2020)
**Unchanged in**:
- Update [36202] (March 30th, 2020)
- Update [36906] (April 29th, 2020)
- Update [37650] (May 27th, 2020)
- Hotfix [37906] (June 2nd, 2020)
- Update [39284] (July 20th, 2020)
- Hotfix [39515] (July 27th, 2020)
- Update [40220] (August 24th, 2020)
- Update [40874] (September 22nd, 2020)
- Update [41855] (October 20th, 2020) |
| 1.40 | ✔️ | ✔️ | Version since game update: [42848] (November 17th, 2020)
**Unchanged in**:
- Hotfix [43210] (November 24th, 2020) |
| 1.41 | ✔️ | ✔️ | Version since game update: [44725] (January 25th, 2021)
**Unchanged in**:
- Hotfix [44834] (January 28th, 2021)
- Hotfix [45185] (February 11th, 2021)
- Update [46265] (March 24th, 2021)
- Update [47820] (May 3rd, 2021) |
| 1.42 | ✔️ | ✔️ | Version since game update: [50292] (July 6th, 2021)
**Unchanged in**:
- Hotfix [50700] (July 13th, 2021) |
| 1.43 | ✔️ | ✔️ | Version since game update: [51737] (August 10th, 2021) |
| 1.44 | ✔️ | ✔️ | Version since game update: [54480] (October 5th, 2021)
**Unchanged in**:
- Hotfix [54684] (October 6th, 2021) |
| 1.45 | ✔️ | ✔️ | Version since game update: [56005] (November 17th, 2021)
**Unchanged in**:
- Update [58259] (January 31st, 2022) |
| 1.46 | ✔️ | ✔️ | Version since game update: [61321] (April 27th, 2022)
**Unchanged in**:
- Update [63482] (June 28th, 2021)
- Hotfix [63581] (July 6th, 2021) |
| 1.47 | ✔️ | ✔️ | Version since game update: [66692] (August 29th, 2022)
**Unchanged in**:
- Update [73855] (December 7th, 2022)
- Update 75350 (Console update) (January 31st, 2023)
- Update [78174] (March 8th, 2023)
- Hotfix [78757] (March 8th, 2023) |
| 1.48 | ✔️ | ✔️ | Version since game update: 79888 (apr_pup 2023) (March 25th, 2023) |
[35584]: https://www.ageofempires.com/news/aoe2de-update-35584/
[36202]: https://www.ageofempires.com/news/aoe2de-update-36202/
[36906]: https://www.ageofempires.com/news/aoe2de-update-36906/
[37650]: https://www.ageofempires.com/news/aoe2de-update-37650/
[37906]: https://www.ageofempires.com/news/aoe2de-hotfix-37906/
[39284]: https://www.ageofempires.com/news/aoe2de-update-39284/
[39515]: https://www.ageofempires.com/news/aoe2de-hotfix-39515/
[40220]: https://www.ageofempires.com/news/aoe2de-update-40220/
[40874]: https://www.ageofempires.com/news/aoe2de-update-40874/
[41855]: https://www.ageofempires.com/news/aoe2de-update-41855/
[42848]: https://www.ageofempires.com/news/aoe2de-update-42848/
[43210]: https://www.ageofempires.com/news/aoe2de-hotfix-43210/
[44725]: https://www.ageofempires.com/news/aoeiide-update-44725/
[44834]: https://www.ageofempires.com/news/aoeiide-update-44725/#hotfix-44834
[45185]: https://www.ageofempires.com/news/aoe2de-hotfix-45185/
[46265]: https://www.ageofempires.com/news/aoe2de-update-46295/
[47820]: https://www.ageofempires.com/news/aoe2de-update-47820/
[50292]: https://www.ageofempires.com/news/aoe2de-update-50292/
[50700]: https://www.ageofempires.com/news/aoe2de-update-50292/#hotfix-50700
[51737]: https://www.ageofempires.com/news/aoeiide-update-51737/
[54480]: https://www.ageofempires.com/news/aoeii-de-update-54480/
[54684]: https://www.ageofempires.com/news/aoeii-de-update-54480/#hotfix-54684
[56005]: https://www.ageofempires.com/news/aoeii_de_update_56005/
[58259]: https://www.ageofempires.com/news/aoe-ii-de-update-58259/
[61321]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-61321/
[63482]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-63482/
[63581]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-63482#Hotfix-63581
[66692]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-66692/
[73855]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-73855/
[78174]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-78174/
[78757]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-78174#641ecbac39a80
# Authors
- Kerwin Sneijders (Main Author)
- [Alian713](https://github.com/Divy1211) (Dataset Wizard)
# License
MIT License: Please see the [LICENSE file].
[license file]: https://github.com/KSneijders/AoE2ScenarioParser/blob/dev/LICENSE
%package help
Summary: Development documents and examples for AoE2ScenarioParser
Provides: python3-AoE2ScenarioParser-doc
%description help
# AoE2ScenarioParser
This is a project for editing parts of an `aoe2scenario` file from **Age of Empires 2 Definitive Edition** outside
the in-game editor.
# Getting started
[GitHub Pages]: https://ksneijders.github.io/AoE2ScenarioParser/
## Quick links
- [Installing AoE2ScenarioParser](https://ksneijders.github.io/AoE2ScenarioParser/installation/)
- [Getting Started](https://ksneijders.github.io/AoE2ScenarioParser/getting_started/)
- [Hello World Example](https://ksneijders.github.io/AoE2ScenarioParser/hello_world/)
- [Discord Server](https://discord.gg/DRUtmugXT3)
- [API Docs](https://ksneijders.github.io/AoE2ScenarioParser/api_docs/aoe2_scenario/)
## Documentation
Documentation can be found on **[GitHub Pages]**.
# Discord
If you have any questions regarding the parser, [join the discord]!
[join the discord]: https://discord.gg/DRUtmugXT3
# Progress
Current up-to-date progress can be found on the [changelog.md] page. (Check the `dev` branch for non-released progress).
[changelog.md]: https://github.com/KSneijders/AoE2ScenarioParser/blob/dev/CHANGELOG.md
## Features:
| | View | Add | Edit | Remove |
|------------|--------------------|---------------------|--------------------|---------------------|
| Triggers | ✔️ | ✔️ | ✔️ | ✔️ |
| Conditions | ✔️ | ✔️ | ✔️ | ✔️ |
| Effects | ✔️ | ✔️ | ✔️ | ✔️ |
| Units | n/a *1 | ✔️ | ✔️ | ✔️ |
| Map | n/a *1 | ✔️ | ✔️ | ✔️ |
| Players | n/a *1 | ✔️* | ✔️ | ✔️* |
*: You can disable or enable players like in the in-game editor (min 1, max 8).
*1: There's no overall formatting function to display these. Though, they can still be printed.
## Support:
| Scenario file version | Read | Write | Reference |
|-----------------------|--------------------|--------------------|-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| 1.36 | ✔️ | ✔️ | Version since the**release of the Definitive Edition** |
| 1.37 | ✔️ | ✔️ | Version since game update: [35584] (February 27th, 2020)
**Unchanged in**:
- Update [36202] (March 30th, 2020)
- Update [36906] (April 29th, 2020)
- Update [37650] (May 27th, 2020)
- Hotfix [37906] (June 2nd, 2020)
- Update [39284] (July 20th, 2020)
- Hotfix [39515] (July 27th, 2020)
- Update [40220] (August 24th, 2020)
- Update [40874] (September 22nd, 2020)
- Update [41855] (October 20th, 2020) |
| 1.40 | ✔️ | ✔️ | Version since game update: [42848] (November 17th, 2020)
**Unchanged in**:
- Hotfix [43210] (November 24th, 2020) |
| 1.41 | ✔️ | ✔️ | Version since game update: [44725] (January 25th, 2021)
**Unchanged in**:
- Hotfix [44834] (January 28th, 2021)
- Hotfix [45185] (February 11th, 2021)
- Update [46265] (March 24th, 2021)
- Update [47820] (May 3rd, 2021) |
| 1.42 | ✔️ | ✔️ | Version since game update: [50292] (July 6th, 2021)
**Unchanged in**:
- Hotfix [50700] (July 13th, 2021) |
| 1.43 | ✔️ | ✔️ | Version since game update: [51737] (August 10th, 2021) |
| 1.44 | ✔️ | ✔️ | Version since game update: [54480] (October 5th, 2021)
**Unchanged in**:
- Hotfix [54684] (October 6th, 2021) |
| 1.45 | ✔️ | ✔️ | Version since game update: [56005] (November 17th, 2021)
**Unchanged in**:
- Update [58259] (January 31st, 2022) |
| 1.46 | ✔️ | ✔️ | Version since game update: [61321] (April 27th, 2022)
**Unchanged in**:
- Update [63482] (June 28th, 2021)
- Hotfix [63581] (July 6th, 2021) |
| 1.47 | ✔️ | ✔️ | Version since game update: [66692] (August 29th, 2022)
**Unchanged in**:
- Update [73855] (December 7th, 2022)
- Update 75350 (Console update) (January 31st, 2023)
- Update [78174] (March 8th, 2023)
- Hotfix [78757] (March 8th, 2023) |
| 1.48 | ✔️ | ✔️ | Version since game update: 79888 (apr_pup 2023) (March 25th, 2023) |
[35584]: https://www.ageofempires.com/news/aoe2de-update-35584/
[36202]: https://www.ageofempires.com/news/aoe2de-update-36202/
[36906]: https://www.ageofempires.com/news/aoe2de-update-36906/
[37650]: https://www.ageofempires.com/news/aoe2de-update-37650/
[37906]: https://www.ageofempires.com/news/aoe2de-hotfix-37906/
[39284]: https://www.ageofempires.com/news/aoe2de-update-39284/
[39515]: https://www.ageofempires.com/news/aoe2de-hotfix-39515/
[40220]: https://www.ageofempires.com/news/aoe2de-update-40220/
[40874]: https://www.ageofempires.com/news/aoe2de-update-40874/
[41855]: https://www.ageofempires.com/news/aoe2de-update-41855/
[42848]: https://www.ageofempires.com/news/aoe2de-update-42848/
[43210]: https://www.ageofempires.com/news/aoe2de-hotfix-43210/
[44725]: https://www.ageofempires.com/news/aoeiide-update-44725/
[44834]: https://www.ageofempires.com/news/aoeiide-update-44725/#hotfix-44834
[45185]: https://www.ageofempires.com/news/aoe2de-hotfix-45185/
[46265]: https://www.ageofempires.com/news/aoe2de-update-46295/
[47820]: https://www.ageofempires.com/news/aoe2de-update-47820/
[50292]: https://www.ageofempires.com/news/aoe2de-update-50292/
[50700]: https://www.ageofempires.com/news/aoe2de-update-50292/#hotfix-50700
[51737]: https://www.ageofempires.com/news/aoeiide-update-51737/
[54480]: https://www.ageofempires.com/news/aoeii-de-update-54480/
[54684]: https://www.ageofempires.com/news/aoeii-de-update-54480/#hotfix-54684
[56005]: https://www.ageofempires.com/news/aoeii_de_update_56005/
[58259]: https://www.ageofempires.com/news/aoe-ii-de-update-58259/
[61321]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-61321/
[63482]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-63482/
[63581]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-63482#Hotfix-63581
[66692]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-66692/
[73855]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-73855/
[78174]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-78174/
[78757]: https://www.ageofempires.com/news/age-of-empires-ii-definitive-edition-update-78174#641ecbac39a80
# Authors
- Kerwin Sneijders (Main Author)
- [Alian713](https://github.com/Divy1211) (Dataset Wizard)
# License
MIT License: Please see the [LICENSE file].
[license file]: https://github.com/KSneijders/AoE2ScenarioParser/blob/dev/LICENSE
%prep
%autosetup -n AoE2ScenarioParser-0.1.53
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-AoE2ScenarioParser -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.1.53-1
- Package Spec generated