%global _empty_manifest_terminate_build 0 Name: python-fireo Version: 2.1.0 Release: 1 Summary: FireO ORM is specifically designed for the Google's Firestore. License: Apache 2.0 URL: https://github.com/octabytes/FireO Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a2/dd/6da1d6bd66c4a5d03b4c8ac5c395074e741c2dc32311e7066746416ce237/fireo-2.1.0.tar.gz BuildArch: noarch Requires: python3-google-cloud-firestore %description

![Build Status](https://github.com/octabytes/FireO/actions/workflows/python-package-testing.yml/badge.svg) PyPI version

FireO Logo

A modern and simplest convenient ORM package in Python. FireO is specifically designed for the Google's Firestore, it's more than just ORM. It implements validation, type checking, relational model logic and much more facilities.

Get Started!




## Available in other language 1. FireO is available also in `nodeJS` [FireO nodeJS](https://github.com/octabytes/fireo-nodejs) ## Installation ```python pip install fireo ``` ## Example Usage ```python from fireo.models import Model from fireo.fields import TextField class User(Model): name = TextField() u = User() u.name = "Azeem Haider" u.save() # Get user user = User.collection.get(u.key) print(user.name) ``` ## With Typed Model ```python from fireo.typedmodels import TypedModel class User(TypedModel): name: str age: int # Use the model as usual: user = User(name='John', age="30") user.save() print(user.to_dict()) ``` ## Documentation Full documentation is available in the [FireO Doc](https://octabyte.io/FireO/). ## Contributing Bug reports and pull requests are welcome. This project is intended to be a safe, welcoming space for collaboration, and contributors are expected to adhere to the [Contributor Covenant](https://github.com/octabytes/FireO/blob/master/CODE_OF_CONDUCT.md) code of conduct. 1. Fix bug or add new features 2. Write tests for your functionality 3. Mention in [Documentation](https://github.com/octabytes/FireO/tree/gh-pages), what you have done and how others can use it To run the tests while developing on this package, you'll have to setup a Google service account and setup credentials with the following command: `export GOOGLE_APPLICATION_CREDENTIALS="KEY_PATH"` See the [Google Cloud documentation](https://cloud.google.com/docs/authentication/getting-started) for more details. ## Code Contributors This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ## License This is official [FireO](https://github.com/octabytes/FireO) Repository. Powered by [OctaByte](https://octabyte.io) Licensed under [Apache License 2.0](https://github.com/octabytes/FireO/blob/master/LICENSE) %package -n python3-fireo Summary: FireO ORM is specifically designed for the Google's Firestore. Provides: python-fireo BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-fireo

![Build Status](https://github.com/octabytes/FireO/actions/workflows/python-package-testing.yml/badge.svg) PyPI version

FireO Logo

A modern and simplest convenient ORM package in Python. FireO is specifically designed for the Google's Firestore, it's more than just ORM. It implements validation, type checking, relational model logic and much more facilities.

Get Started!




## Available in other language 1. FireO is available also in `nodeJS` [FireO nodeJS](https://github.com/octabytes/fireo-nodejs) ## Installation ```python pip install fireo ``` ## Example Usage ```python from fireo.models import Model from fireo.fields import TextField class User(Model): name = TextField() u = User() u.name = "Azeem Haider" u.save() # Get user user = User.collection.get(u.key) print(user.name) ``` ## With Typed Model ```python from fireo.typedmodels import TypedModel class User(TypedModel): name: str age: int # Use the model as usual: user = User(name='John', age="30") user.save() print(user.to_dict()) ``` ## Documentation Full documentation is available in the [FireO Doc](https://octabyte.io/FireO/). ## Contributing Bug reports and pull requests are welcome. This project is intended to be a safe, welcoming space for collaboration, and contributors are expected to adhere to the [Contributor Covenant](https://github.com/octabytes/FireO/blob/master/CODE_OF_CONDUCT.md) code of conduct. 1. Fix bug or add new features 2. Write tests for your functionality 3. Mention in [Documentation](https://github.com/octabytes/FireO/tree/gh-pages), what you have done and how others can use it To run the tests while developing on this package, you'll have to setup a Google service account and setup credentials with the following command: `export GOOGLE_APPLICATION_CREDENTIALS="KEY_PATH"` See the [Google Cloud documentation](https://cloud.google.com/docs/authentication/getting-started) for more details. ## Code Contributors This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ## License This is official [FireO](https://github.com/octabytes/FireO) Repository. Powered by [OctaByte](https://octabyte.io) Licensed under [Apache License 2.0](https://github.com/octabytes/FireO/blob/master/LICENSE) %package help Summary: Development documents and examples for fireo Provides: python3-fireo-doc %description help

![Build Status](https://github.com/octabytes/FireO/actions/workflows/python-package-testing.yml/badge.svg) PyPI version

FireO Logo

A modern and simplest convenient ORM package in Python. FireO is specifically designed for the Google's Firestore, it's more than just ORM. It implements validation, type checking, relational model logic and much more facilities.

Get Started!




## Available in other language 1. FireO is available also in `nodeJS` [FireO nodeJS](https://github.com/octabytes/fireo-nodejs) ## Installation ```python pip install fireo ``` ## Example Usage ```python from fireo.models import Model from fireo.fields import TextField class User(Model): name = TextField() u = User() u.name = "Azeem Haider" u.save() # Get user user = User.collection.get(u.key) print(user.name) ``` ## With Typed Model ```python from fireo.typedmodels import TypedModel class User(TypedModel): name: str age: int # Use the model as usual: user = User(name='John', age="30") user.save() print(user.to_dict()) ``` ## Documentation Full documentation is available in the [FireO Doc](https://octabyte.io/FireO/). ## Contributing Bug reports and pull requests are welcome. This project is intended to be a safe, welcoming space for collaboration, and contributors are expected to adhere to the [Contributor Covenant](https://github.com/octabytes/FireO/blob/master/CODE_OF_CONDUCT.md) code of conduct. 1. Fix bug or add new features 2. Write tests for your functionality 3. Mention in [Documentation](https://github.com/octabytes/FireO/tree/gh-pages), what you have done and how others can use it To run the tests while developing on this package, you'll have to setup a Google service account and setup credentials with the following command: `export GOOGLE_APPLICATION_CREDENTIALS="KEY_PATH"` See the [Google Cloud documentation](https://cloud.google.com/docs/authentication/getting-started) for more details. ## Code Contributors This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ## License This is official [FireO](https://github.com/octabytes/FireO) Repository. Powered by [OctaByte](https://octabyte.io) Licensed under [Apache License 2.0](https://github.com/octabytes/FireO/blob/master/LICENSE) %prep %autosetup -n fireo-2.1.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-fireo -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Apr 25 2023 Python_Bot - 2.1.0-1 - Package Spec generated