%global _empty_manifest_terminate_build 0
Name: python-debops
Version: 3.0.4
Release: 1
Summary: Your Debian-based data center in a box
License: GPL-3.0-or-later
URL: https://debops.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cf/33/7d99a5c454260954c52768f0b7f2301d7fa963887b1c1aea691acf974759/debops-3.0.4.tar.gz
BuildArch: noarch
Requires: python3-distro
Requires: python3-future
Requires: python3-jinja2
Requires: python3-dotenv
Requires: python3-pyxdg
Requires: python3-pyyaml
Requires: python3-toml
Requires: python3-ansible
Requires: python3-dnspython
Requires: python3-netaddr
Requires: python3-passlib
Requires: python3-pyopenssl
Requires: python3-ldap
%description
*Your Debian-based data center in a box*
|GitHub CI| |GitLab CI| |CII Best Practices| |REUSE status| |RSS
commits|
The DebOps project provides a set of general-purpose
`Ansible `__ roles that can be used
to manage `Debian `__ or
`Ubuntu `__ hosts. In addition, a default set
of Ansible playbooks can be used to apply the provided roles in a
controlled way, using Ansible inventory groups.
The roles are written with a high customization in mind, which can be
done using Ansible inventory. This way the role and playbook code can be
shared between multiple environments, with different configuration in to
each one.
Services can be managed on a single host, or spread between multiple
hosts. DebOps provides support for different SQL and NoSQL databases,
web servers, programming languages and specialized applications useful
in a data center environment or in a cluster. The project can also be
used to deploy virtualization environments using KVM/libvirt, Docker or
LXC technologies to manage virtual machines and/or containers.
You can find out more about DebOps features on the `project’s
documentation page `__.
%package -n python3-debops
Summary: Your Debian-based data center in a box
Provides: python-debops
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-debops
*Your Debian-based data center in a box*
|GitHub CI| |GitLab CI| |CII Best Practices| |REUSE status| |RSS
commits|
The DebOps project provides a set of general-purpose
`Ansible `__ roles that can be used
to manage `Debian `__ or
`Ubuntu `__ hosts. In addition, a default set
of Ansible playbooks can be used to apply the provided roles in a
controlled way, using Ansible inventory groups.
The roles are written with a high customization in mind, which can be
done using Ansible inventory. This way the role and playbook code can be
shared between multiple environments, with different configuration in to
each one.
Services can be managed on a single host, or spread between multiple
hosts. DebOps provides support for different SQL and NoSQL databases,
web servers, programming languages and specialized applications useful
in a data center environment or in a cluster. The project can also be
used to deploy virtualization environments using KVM/libvirt, Docker or
LXC technologies to manage virtual machines and/or containers.
You can find out more about DebOps features on the `project’s
documentation page `__.
%package help
Summary: Development documents and examples for debops
Provides: python3-debops-doc
%description help
*Your Debian-based data center in a box*
|GitHub CI| |GitLab CI| |CII Best Practices| |REUSE status| |RSS
commits|
The DebOps project provides a set of general-purpose
`Ansible `__ roles that can be used
to manage `Debian `__ or
`Ubuntu `__ hosts. In addition, a default set
of Ansible playbooks can be used to apply the provided roles in a
controlled way, using Ansible inventory groups.
The roles are written with a high customization in mind, which can be
done using Ansible inventory. This way the role and playbook code can be
shared between multiple environments, with different configuration in to
each one.
Services can be managed on a single host, or spread between multiple
hosts. DebOps provides support for different SQL and NoSQL databases,
web servers, programming languages and specialized applications useful
in a data center environment or in a cluster. The project can also be
used to deploy virtualization environments using KVM/libvirt, Docker or
LXC technologies to manage virtual machines and/or containers.
You can find out more about DebOps features on the `project’s
documentation page `__.
%prep
%autosetup -n debops-3.0.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-debops -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 3.0.4-1
- Package Spec generated