%global _empty_manifest_terminate_build 0
Name: python-django-tz-detect
Version: 0.4.0
Release: 1
Summary: Automatic user timezone detection for django
License: MIT License
URL: http://github.com/adamcharnock/django-tz-detect
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/75/66/03b36aa969d93330556a658f2bcca3511ab594f43ffedf672cc042cfd06d/django-tz-detect-0.4.0.tar.gz
BuildArch: noarch
Requires: python3-django
Requires: python3-pytz
%description
This app will auto-detect a user's timezone using JavaScript, then
configure Django's timezone localization system accordingly. As a
result, dates shown to users will be in their local timezones.
Authored by `Adam Charnock `_, and some great `contributors `_.
%package -n python3-django-tz-detect
Summary: Automatic user timezone detection for django
Provides: python-django-tz-detect
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-tz-detect
This app will auto-detect a user's timezone using JavaScript, then
configure Django's timezone localization system accordingly. As a
result, dates shown to users will be in their local timezones.
Authored by `Adam Charnock `_, and some great `contributors `_.
%package help
Summary: Development documents and examples for django-tz-detect
Provides: python3-django-tz-detect-doc
%description help
This app will auto-detect a user's timezone using JavaScript, then
configure Django's timezone localization system accordingly. As a
result, dates shown to users will be in their local timezones.
Authored by `Adam Charnock `_, and some great `contributors `_.
%prep
%autosetup -n django-tz-detect-0.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-tz-detect -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.4.0-1
- Package Spec generated