%global _empty_manifest_terminate_build 0
Name: python-sphinx-reredirects
Version: 0.1.1
Release: 1
Summary: Handles redirects for moved pages in Sphinx documentation projects
License: BSD3
URL: https://gitlab.com/documatt/sphinx-reredirects
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b5/3a/195268759a3ff138f2ff32d6535f94cb9199671ed4832142a6a1d6f1a3fa/sphinx_reredirects-0.1.1.tar.gz
BuildArch: noarch
Requires: python3-sphinx
%description
##################
sphinx-reredirects
##################
.. image:: https://img.icons8.com/wired/64/undefined/forward-arrow--v1.png
:align: right
.. image:: https://gitlab.com/documatt/sphinx-reredirects/badges/master/pipeline.svg
:target: https://gitlab.com/documatt/sphinx-reredirects/-/commits/master
.. image:: https://img.shields.io/badge/code%20style-black-000000.svg
:target: https://github.com/psf/black
.. image:: https://img.shields.io/pypi/v/sphinx-reredirects
:target: https://pypi.org/project/sphinx-reredirects/
sphinx-reredirects is the extension for `Sphinx documentation `_ projects that handles redirects for moved pages. It generates HTML pages with meta refresh redirects to the new page location to prevent 404 errors if you rename or move your documents.
* docs: https://documatt.gitlab.io/sphinx-reredirects
* code: https://gitlab.com/documatt/sphinx-reredirects where issues and contributions are welcome
Good URLs are never changing URLs. But if you must, sphinx-reredirects helps you manage redirects with ease and from the single place in project's ``conf.py``. For example, if you rename document ``start`` to ``intro``, and tell it to sphinx-reredirects, it will generate HTML page ``start.html`` with ````. The extension supports wildcards and moving to different domain too.
*****
About
*****
sphinx-reredirects started from the urge to manage redirects for all documents during moving our *Tech writer at work blog* to the new domain https://techwriter.documatt.com.
*****
Legal
*****
Forward Arrow icon by `Icons8 `_.
sphinx-reredirects is licensed under BSD3.
%package -n python3-sphinx-reredirects
Summary: Handles redirects for moved pages in Sphinx documentation projects
Provides: python-sphinx-reredirects
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sphinx-reredirects
##################
sphinx-reredirects
##################
.. image:: https://img.icons8.com/wired/64/undefined/forward-arrow--v1.png
:align: right
.. image:: https://gitlab.com/documatt/sphinx-reredirects/badges/master/pipeline.svg
:target: https://gitlab.com/documatt/sphinx-reredirects/-/commits/master
.. image:: https://img.shields.io/badge/code%20style-black-000000.svg
:target: https://github.com/psf/black
.. image:: https://img.shields.io/pypi/v/sphinx-reredirects
:target: https://pypi.org/project/sphinx-reredirects/
sphinx-reredirects is the extension for `Sphinx documentation `_ projects that handles redirects for moved pages. It generates HTML pages with meta refresh redirects to the new page location to prevent 404 errors if you rename or move your documents.
* docs: https://documatt.gitlab.io/sphinx-reredirects
* code: https://gitlab.com/documatt/sphinx-reredirects where issues and contributions are welcome
Good URLs are never changing URLs. But if you must, sphinx-reredirects helps you manage redirects with ease and from the single place in project's ``conf.py``. For example, if you rename document ``start`` to ``intro``, and tell it to sphinx-reredirects, it will generate HTML page ``start.html`` with ````. The extension supports wildcards and moving to different domain too.
*****
About
*****
sphinx-reredirects started from the urge to manage redirects for all documents during moving our *Tech writer at work blog* to the new domain https://techwriter.documatt.com.
*****
Legal
*****
Forward Arrow icon by `Icons8 `_.
sphinx-reredirects is licensed under BSD3.
%package help
Summary: Development documents and examples for sphinx-reredirects
Provides: python3-sphinx-reredirects-doc
%description help
##################
sphinx-reredirects
##################
.. image:: https://img.icons8.com/wired/64/undefined/forward-arrow--v1.png
:align: right
.. image:: https://gitlab.com/documatt/sphinx-reredirects/badges/master/pipeline.svg
:target: https://gitlab.com/documatt/sphinx-reredirects/-/commits/master
.. image:: https://img.shields.io/badge/code%20style-black-000000.svg
:target: https://github.com/psf/black
.. image:: https://img.shields.io/pypi/v/sphinx-reredirects
:target: https://pypi.org/project/sphinx-reredirects/
sphinx-reredirects is the extension for `Sphinx documentation `_ projects that handles redirects for moved pages. It generates HTML pages with meta refresh redirects to the new page location to prevent 404 errors if you rename or move your documents.
* docs: https://documatt.gitlab.io/sphinx-reredirects
* code: https://gitlab.com/documatt/sphinx-reredirects where issues and contributions are welcome
Good URLs are never changing URLs. But if you must, sphinx-reredirects helps you manage redirects with ease and from the single place in project's ``conf.py``. For example, if you rename document ``start`` to ``intro``, and tell it to sphinx-reredirects, it will generate HTML page ``start.html`` with ````. The extension supports wildcards and moving to different domain too.
*****
About
*****
sphinx-reredirects started from the urge to manage redirects for all documents during moving our *Tech writer at work blog* to the new domain https://techwriter.documatt.com.
*****
Legal
*****
Forward Arrow icon by `Icons8 `_.
sphinx-reredirects is licensed under BSD3.
%prep
%autosetup -n sphinx-reredirects-0.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sphinx-reredirects -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.1.1-1
- Package Spec generated