%global _empty_manifest_terminate_build 0
Name:		python-Eve-Elastic
Version:	7.3.1
Release:	1
Summary:	Elasticsearch data layer for eve rest framework
License:	GPLv3+
URL:		https://github.com/petrjasek/eve-elastic
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/93/ab/4de80e5ee85ee0ba425b8188044f96036a424397fc4f87acb8b245b6eee4/Eve-Elastic-7.3.1.tar.gz
BuildArch:	noarch

Requires:	python3-arrow
Requires:	python3-ciso8601
Requires:	python3-pytz
Requires:	python3-elasticsearch

%description
Eve-Elastic is `elastic <http://www.elasticsearch.org>`_ data layer for `eve REST framework <http://python-eve.org>`_.

%package -n python3-Eve-Elastic
Summary:	Elasticsearch data layer for eve rest framework
Provides:	python-Eve-Elastic
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Eve-Elastic
Eve-Elastic is `elastic <http://www.elasticsearch.org>`_ data layer for `eve REST framework <http://python-eve.org>`_.

%package help
Summary:	Development documents and examples for Eve-Elastic
Provides:	python3-Eve-Elastic-doc
%description help
Eve-Elastic is `elastic <http://www.elasticsearch.org>`_ data layer for `eve REST framework <http://python-eve.org>`_.

%prep
%autosetup -n Eve-Elastic-7.3.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Eve-Elastic -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 7.3.1-1
- Package Spec generated