%global _empty_manifest_terminate_build 0
Name: python-pymagnitude
Version: 0.1.143
Release: 1
Summary: A fast, efficient universal vector embedding utility package.
License: MIT
URL: https://gitlab.com/Plasticity/magnitude
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/69/40/ec05f0630f6dd56eb323dee5bc70a52e4f21247185d8662d3d08267cc6c7/pymagnitude-0.1.143.tar.gz
BuildArch: noarch
%description
A feature-packed Python package and vector storage file format for utilizing vector embeddings in machine learning models in a fast, efficient, and simple manner developed by `Plasticity `_. It is primarily intended to be a faster alternative to `Gensim `_, but can be used as a generic key-vector store for domains outside NLP.
%package -n python3-pymagnitude
Summary: A fast, efficient universal vector embedding utility package.
Provides: python-pymagnitude
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pymagnitude
A feature-packed Python package and vector storage file format for utilizing vector embeddings in machine learning models in a fast, efficient, and simple manner developed by `Plasticity `_. It is primarily intended to be a faster alternative to `Gensim `_, but can be used as a generic key-vector store for domains outside NLP.
%package help
Summary: Development documents and examples for pymagnitude
Provides: python3-pymagnitude-doc
%description help
A feature-packed Python package and vector storage file format for utilizing vector embeddings in machine learning models in a fast, efficient, and simple manner developed by `Plasticity `_. It is primarily intended to be a faster alternative to `Gensim `_, but can be used as a generic key-vector store for domains outside NLP.
%prep
%autosetup -n pymagnitude-0.1.143
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pymagnitude -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.1.143-1
- Package Spec generated