%global _empty_manifest_terminate_build 0
Name: python-epsie
Version: 1.0.0
Release: 1
Summary: An Embarrassingly Parallel Sampler for Inference Estimation.
License: GNU General Public License v3 (GPLv3)
URL: https://cdcapano.github.io/epsie
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/21/50/dcb58a1cdbbc9e62c8c059b1f5b5f3e2a6ca6ecbd5d996ceca2a1e540873/epsie-1.0.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-six
%description
EPSIE is a parallelized Markov chain Monte Carlo (MCMC) sampler for Bayesian
inference. It is meant for problems with complicated likelihood topology,
including multimodal distributions. It has support for both parallel tempering
and nested transdimensional problems. It was originally developed for
gravitational-wave parameter estimation, but can be used for any Bayesian
inference problem requring a stochastic sampler.
EPSIE is in many ways similar to `emcee
`_ and other bring-your-own-likelihood
Python-based samplers. The primary difference from emcee is EPSIE
is not an ensemble sampler; i.e., the Markov chains used by EPSIE do not
attempt to share information between each other. Instead, to speed convergence,
multiple jump proposal classes are offered that can be customized to the
problem at hand. These include adaptive proposals that attempt to learn the
shape of the distribution during a burn-in period. The user can also easily
create their own jump proposals.
For more information, see the documentation at:
https://cdcapano.github.io/epsie
%package -n python3-epsie
Summary: An Embarrassingly Parallel Sampler for Inference Estimation.
Provides: python-epsie
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-epsie
EPSIE is a parallelized Markov chain Monte Carlo (MCMC) sampler for Bayesian
inference. It is meant for problems with complicated likelihood topology,
including multimodal distributions. It has support for both parallel tempering
and nested transdimensional problems. It was originally developed for
gravitational-wave parameter estimation, but can be used for any Bayesian
inference problem requring a stochastic sampler.
EPSIE is in many ways similar to `emcee
`_ and other bring-your-own-likelihood
Python-based samplers. The primary difference from emcee is EPSIE
is not an ensemble sampler; i.e., the Markov chains used by EPSIE do not
attempt to share information between each other. Instead, to speed convergence,
multiple jump proposal classes are offered that can be customized to the
problem at hand. These include adaptive proposals that attempt to learn the
shape of the distribution during a burn-in period. The user can also easily
create their own jump proposals.
For more information, see the documentation at:
https://cdcapano.github.io/epsie
%package help
Summary: Development documents and examples for epsie
Provides: python3-epsie-doc
%description help
EPSIE is a parallelized Markov chain Monte Carlo (MCMC) sampler for Bayesian
inference. It is meant for problems with complicated likelihood topology,
including multimodal distributions. It has support for both parallel tempering
and nested transdimensional problems. It was originally developed for
gravitational-wave parameter estimation, but can be used for any Bayesian
inference problem requring a stochastic sampler.
EPSIE is in many ways similar to `emcee
`_ and other bring-your-own-likelihood
Python-based samplers. The primary difference from emcee is EPSIE
is not an ensemble sampler; i.e., the Markov chains used by EPSIE do not
attempt to share information between each other. Instead, to speed convergence,
multiple jump proposal classes are offered that can be customized to the
problem at hand. These include adaptive proposals that attempt to learn the
shape of the distribution during a burn-in period. The user can also easily
create their own jump proposals.
For more information, see the documentation at:
https://cdcapano.github.io/epsie
%prep
%autosetup -n epsie-1.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-epsie -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.0.0-1
- Package Spec generated