%global _empty_manifest_terminate_build 0
Name: python-pyworxcloud
Version: 3.1.4
Release: 1
Summary: Landroid cloud (Positec) API library
License: MIT
URL: https://pypi.org/project/pyworxcloud/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c9/c9/0e5f93a81a6d2a350f4fc737af8befc397fde88bcdf459fbee0a98245ad8/pyworxcloud-3.1.4.tar.gz
BuildArch: noarch
Requires: python3-urllib3
Requires: python3-requests
Requires: python3-paho-mqtt
%description
# pyWorxCloud
This is a PyPI module for communicating with Worx Cloud mowers, primarily developed for use with [Home Assistant](https://home-assistant.io), but I try to keep it as widely usable as possible.
The module are compatible with cloud enabled devices from [these vendors](https://github.com/MTrab/pyworxcloud/wiki#current-supported-brands--vendors)
## Documentation
The documentation have been moved to the [Wiki](https://github.com/MTrab/pyworxcloud/wiki)
This is unfortunately a little out-of-date due to the huge changes in version 3.
%package -n python3-pyworxcloud
Summary: Landroid cloud (Positec) API library
Provides: python-pyworxcloud
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyworxcloud
# pyWorxCloud
This is a PyPI module for communicating with Worx Cloud mowers, primarily developed for use with [Home Assistant](https://home-assistant.io), but I try to keep it as widely usable as possible.
The module are compatible with cloud enabled devices from [these vendors](https://github.com/MTrab/pyworxcloud/wiki#current-supported-brands--vendors)
## Documentation
The documentation have been moved to the [Wiki](https://github.com/MTrab/pyworxcloud/wiki)
This is unfortunately a little out-of-date due to the huge changes in version 3.
%package help
Summary: Development documents and examples for pyworxcloud
Provides: python3-pyworxcloud-doc
%description help
# pyWorxCloud
This is a PyPI module for communicating with Worx Cloud mowers, primarily developed for use with [Home Assistant](https://home-assistant.io), but I try to keep it as widely usable as possible.
The module are compatible with cloud enabled devices from [these vendors](https://github.com/MTrab/pyworxcloud/wiki#current-supported-brands--vendors)
## Documentation
The documentation have been moved to the [Wiki](https://github.com/MTrab/pyworxcloud/wiki)
This is unfortunately a little out-of-date due to the huge changes in version 3.
%prep
%autosetup -n pyworxcloud-3.1.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyworxcloud -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 3.1.4-1
- Package Spec generated