%global _empty_manifest_terminate_build 0
Name:		python-ai-tools
Version:	0.3.9
Release:	1
Summary:	basic tools for ai
License:	MIT
URL:		http://www.zhaomingming.cn
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/92/a3/206c2f5003eb09ea3b7311aa60b2215544aefb519b6956ef576ed9ba619a/ai_tools-0.3.9.tar.gz
BuildArch:	noarch

Requires:	python3-check-manifest
Requires:	python3-coverage

%description
`ai_tool 2018-05-25`
`Author: Zhao Mingming <471106585@qq.com>`
`Copyright: This module has been placed in the public domain.`
`version:0.0.6`
`version:0.1.0`
- `add func roc`	
- `add func photo_stiching`
- `add func flv2img`
`version:0.1.1`
- `add func microsoft_demo`
`version:0.1.3`
- `add func luminance`
`version:0.1.4`
- `add func dbop ,opreate the database`
`version:0.1.5`
- `add func util, make the print has time`
`version:0.1.6`
- `add func txt2html, make the txt 2 html table`
`version:0.1.8`
- `modify file microsoft_demo, add zprint into it`
`version:0.1.9`
- `modify roc_yolo`
`version:0.2.1`
- `modify insert_image2db, can insert data into 2 database`
`version:0.2.3`
- `add class2info.py function is get_class_info`
`version:0.2.4`
- `add darkchannel.py to decreate the haze of an image`
`version:0.2.7`
- `add lumi_classfy to luminance.py`
`version:0.3.1`
- `add modify video2img`
`version:0.3.3`
- `add wjdc`
- `add video2gif`
`version:0.3.6`
- `add get_histfeature_from_one_img`
Functions:
- `draw_curve`: draw a curve in a image and return the image 
- `image2text`: translate a image to be text style
- `save2server`: save a image on the local server 
- `image2bw`:  turn a gray image to be a binary weights image

%package -n python3-ai-tools
Summary:	basic tools for ai
Provides:	python-ai-tools
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ai-tools
`ai_tool 2018-05-25`
`Author: Zhao Mingming <471106585@qq.com>`
`Copyright: This module has been placed in the public domain.`
`version:0.0.6`
`version:0.1.0`
- `add func roc`	
- `add func photo_stiching`
- `add func flv2img`
`version:0.1.1`
- `add func microsoft_demo`
`version:0.1.3`
- `add func luminance`
`version:0.1.4`
- `add func dbop ,opreate the database`
`version:0.1.5`
- `add func util, make the print has time`
`version:0.1.6`
- `add func txt2html, make the txt 2 html table`
`version:0.1.8`
- `modify file microsoft_demo, add zprint into it`
`version:0.1.9`
- `modify roc_yolo`
`version:0.2.1`
- `modify insert_image2db, can insert data into 2 database`
`version:0.2.3`
- `add class2info.py function is get_class_info`
`version:0.2.4`
- `add darkchannel.py to decreate the haze of an image`
`version:0.2.7`
- `add lumi_classfy to luminance.py`
`version:0.3.1`
- `add modify video2img`
`version:0.3.3`
- `add wjdc`
- `add video2gif`
`version:0.3.6`
- `add get_histfeature_from_one_img`
Functions:
- `draw_curve`: draw a curve in a image and return the image 
- `image2text`: translate a image to be text style
- `save2server`: save a image on the local server 
- `image2bw`:  turn a gray image to be a binary weights image

%package help
Summary:	Development documents and examples for ai-tools
Provides:	python3-ai-tools-doc
%description help
`ai_tool 2018-05-25`
`Author: Zhao Mingming <471106585@qq.com>`
`Copyright: This module has been placed in the public domain.`
`version:0.0.6`
`version:0.1.0`
- `add func roc`	
- `add func photo_stiching`
- `add func flv2img`
`version:0.1.1`
- `add func microsoft_demo`
`version:0.1.3`
- `add func luminance`
`version:0.1.4`
- `add func dbop ,opreate the database`
`version:0.1.5`
- `add func util, make the print has time`
`version:0.1.6`
- `add func txt2html, make the txt 2 html table`
`version:0.1.8`
- `modify file microsoft_demo, add zprint into it`
`version:0.1.9`
- `modify roc_yolo`
`version:0.2.1`
- `modify insert_image2db, can insert data into 2 database`
`version:0.2.3`
- `add class2info.py function is get_class_info`
`version:0.2.4`
- `add darkchannel.py to decreate the haze of an image`
`version:0.2.7`
- `add lumi_classfy to luminance.py`
`version:0.3.1`
- `add modify video2img`
`version:0.3.3`
- `add wjdc`
- `add video2gif`
`version:0.3.6`
- `add get_histfeature_from_one_img`
Functions:
- `draw_curve`: draw a curve in a image and return the image 
- `image2text`: translate a image to be text style
- `save2server`: save a image on the local server 
- `image2bw`:  turn a gray image to be a binary weights image

%prep
%autosetup -n ai-tools-0.3.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ai-tools -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.9-1
- Package Spec generated