%global _empty_manifest_terminate_build 0
Name: python-Flask-Webpack
Version: 0.1.0
Release: 1
Summary: Flask extension for managing assets with Webpack.
License: GPLv3
URL: https://github.com/nickjj/flask-webpack
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8a/20/d65d148939e75f860b059f3d960ccdd316da599a9ee54462d9b53821d16c/Flask-Webpack-0.1.0.tar.gz
BuildArch: noarch
%description
It sets up a few template tags so you can access the assets inside of your
jinja templates.
**It means you can type this:**
``
``
**...and once your jinja template has been compiled, you will see this:**
``
``
Now you can happily tell your frontend proxy to cache that hamburger image for
an entire year. If you ever change the hamburger, the md5 will change but you
do not need to change any of your templates because the ``asset_url_for``
tag knows how to look it up.
%package -n python3-Flask-Webpack
Summary: Flask extension for managing assets with Webpack.
Provides: python-Flask-Webpack
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Flask-Webpack
It sets up a few template tags so you can access the assets inside of your
jinja templates.
**It means you can type this:**
``
``
**...and once your jinja template has been compiled, you will see this:**
``
``
Now you can happily tell your frontend proxy to cache that hamburger image for
an entire year. If you ever change the hamburger, the md5 will change but you
do not need to change any of your templates because the ``asset_url_for``
tag knows how to look it up.
%package help
Summary: Development documents and examples for Flask-Webpack
Provides: python3-Flask-Webpack-doc
%description help
It sets up a few template tags so you can access the assets inside of your
jinja templates.
**It means you can type this:**
``
``
**...and once your jinja template has been compiled, you will see this:**
``
``
Now you can happily tell your frontend proxy to cache that hamburger image for
an entire year. If you ever change the hamburger, the md5 will change but you
do not need to change any of your templates because the ``asset_url_for``
tag knows how to look it up.
%prep
%autosetup -n Flask-Webpack-0.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Flask-Webpack -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.1.0-1
- Package Spec generated