%global _empty_manifest_terminate_build 0
Name: python-TDhelper
Version: 2.4.5
Release: 1
Summary: reconsitution web.permissionHelper cls.
License: Apache 2.0
URL: https://gitee.com/TonyDon/pyLib
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4a/67/150e431f4c6940ef3e8d7adcdd0763c872922dff4b48ebf44afa246245d0/TDhelper-2.4.5.tar.gz
BuildArch: noarch
Requires: python3-asgiref
Requires: python3-bleach
Requires: python3-certifi
Requires: python3-cffi
Requires: python3-chardet
Requires: python3-colorama
Requires: python3-crypto
Requires: python3-cryptography
Requires: python3-dnspython
Requires: python3-docutils
Requires: python3-et-xmlfile
Requires: python3-gyp-next
Requires: python3-idna
Requires: python3-importlib-metadata
Requires: python3-jdcal
Requires: python3-keyring
Requires: python3-mysql-connector-python
Requires: python3-Naked
Requires: python3-openpyxl
Requires: python3-packaging
Requires: python3-pkginfo
Requires: python3-protobuf
Requires: python3-pycparser
Requires: python3-pycryptodome
Requires: python3-Pygments
Requires: python3-pymongo
Requires: python3-pyparsing
Requires: python3-dateutil
Requires: python3-pytz
Requires: python3-pywin32-ctypes
Requires: python3-PyYAML
Requires: python3-readme-renderer
Requires: python3-requests
Requires: python3-requests-toolbelt
Requires: python3-rfc3986
Requires: python3-shellescape
Requires: python3-six
Requires: python3-sqlparse
Requires: python3-tqdm
Requires: python3-typing-extensions
Requires: python3-urllib3
Requires: python3-webencodings
Requires: python3-xlrd
Requires: python3-zipp
%description
# TDhelper LIb
helper class lib.
# ***Cache***
## 1. pools
## 2. ring cache
# ***db***
## 1. sqllite
## 2. mongodb
## 3. mysql
# ***Decorators***
## 1. log
# ***document***
## 1. file
## 2. excel
# ***Event***
## 1. Event
## 2. classEvent
## 3. webEvent
# ***generic***
# ***MagicCls***
running time dynamic create class.
mapping any object to an object.
# ***Msg***
genneric msg helper class.
# ***network***
http, socket helper.
# ***robot***
robot class.
# ***Scheduler***
not finished
# ***simulate***
not finished
# ***Spider***
# ***structs***
not finished
# ***web***
## permission module
### ***1. register***
permission register class.
#### ***Methods***
NO.
| name
| description
:---:|:---|:---
1 | [Register](#perRegister) | -
2 | [RegisterByCfg](#perRegisterByCfg) | -
***Register***
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
serviceClass | - | class | yes | -
***RegisterByCfg***
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
Cfg | - | dict | yes | -
### ***2. perACL***
#### web project check ACL.
#### ***Methods***
NO.
| name
| description
:---:|:---|:---
1 | [perACL](#perACL) | -
2 | [addRPCHandle](#addRPCHandle) | -
3 | [AccessControlLists](#accessControlLists) | -
***perACL***
Initialize.
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
rpc_key | - | str | yes | -
params_container_class | - | str | yes | -
platformKey | - | str | no | None
tokenKey | - | str | no | usr-token
***addRPCHandle***
Add ACL RPC handle method.
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
handle | - | RPC | yes | -
***AccessControlLists***
decotrator method. @perACL.accessControlLists()
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
premissionKey | - | str | no | None
debug | - | Boolen | no | False
%package -n python3-TDhelper
Summary: reconsitution web.permissionHelper cls.
Provides: python-TDhelper
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-TDhelper
# TDhelper LIb
helper class lib.
# ***Cache***
## 1. pools
## 2. ring cache
# ***db***
## 1. sqllite
## 2. mongodb
## 3. mysql
# ***Decorators***
## 1. log
# ***document***
## 1. file
## 2. excel
# ***Event***
## 1. Event
## 2. classEvent
## 3. webEvent
# ***generic***
# ***MagicCls***
running time dynamic create class.
mapping any object to an object.
# ***Msg***
genneric msg helper class.
# ***network***
http, socket helper.
# ***robot***
robot class.
# ***Scheduler***
not finished
# ***simulate***
not finished
# ***Spider***
# ***structs***
not finished
# ***web***
## permission module
### ***1. register***
permission register class.
#### ***Methods***
NO.
| name
| description
:---:|:---|:---
1 | [Register](#perRegister) | -
2 | [RegisterByCfg](#perRegisterByCfg) | -
***Register***
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
serviceClass | - | class | yes | -
***RegisterByCfg***
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
Cfg | - | dict | yes | -
### ***2. perACL***
#### web project check ACL.
#### ***Methods***
NO.
| name
| description
:---:|:---|:---
1 | [perACL](#perACL) | -
2 | [addRPCHandle](#addRPCHandle) | -
3 | [AccessControlLists](#accessControlLists) | -
***perACL***
Initialize.
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
rpc_key | - | str | yes | -
params_container_class | - | str | yes | -
platformKey | - | str | no | None
tokenKey | - | str | no | usr-token
***addRPCHandle***
Add ACL RPC handle method.
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
handle | - | RPC | yes | -
***AccessControlLists***
decotrator method. @perACL.accessControlLists()
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
premissionKey | - | str | no | None
debug | - | Boolen | no | False
%package help
Summary: Development documents and examples for TDhelper
Provides: python3-TDhelper-doc
%description help
# TDhelper LIb
helper class lib.
# ***Cache***
## 1. pools
## 2. ring cache
# ***db***
## 1. sqllite
## 2. mongodb
## 3. mysql
# ***Decorators***
## 1. log
# ***document***
## 1. file
## 2. excel
# ***Event***
## 1. Event
## 2. classEvent
## 3. webEvent
# ***generic***
# ***MagicCls***
running time dynamic create class.
mapping any object to an object.
# ***Msg***
genneric msg helper class.
# ***network***
http, socket helper.
# ***robot***
robot class.
# ***Scheduler***
not finished
# ***simulate***
not finished
# ***Spider***
# ***structs***
not finished
# ***web***
## permission module
### ***1. register***
permission register class.
#### ***Methods***
NO.
| name
| description
:---:|:---|:---
1 | [Register](#perRegister) | -
2 | [RegisterByCfg](#perRegisterByCfg) | -
***Register***
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
serviceClass | - | class | yes | -
***RegisterByCfg***
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
Cfg | - | dict | yes | -
### ***2. perACL***
#### web project check ACL.
#### ***Methods***
NO.
| name
| description
:---:|:---|:---
1 | [perACL](#perACL) | -
2 | [addRPCHandle](#addRPCHandle) | -
3 | [AccessControlLists](#accessControlLists) | -
***perACL***
Initialize.
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
rpc_key | - | str | yes | -
params_container_class | - | str | yes | -
platformKey | - | str | no | None
tokenKey | - | str | no | usr-token
***addRPCHandle***
Add ACL RPC handle method.
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
handle | - | RPC | yes | -
***AccessControlLists***
decotrator method. @perACL.accessControlLists()
name
| description
| type | required | default
:--- | :--- | :---: | :---: | :---
premissionKey | - | str | no | None
debug | - | Boolen | no | False
%prep
%autosetup -n TDhelper-2.4.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-TDhelper -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.4.5-1
- Package Spec generated