%global _empty_manifest_terminate_build 0
Name: python-epydoc
Version: 3.0.1
Release: 1
Summary: Edward Loper's API Documentation Generation Tool
License: IBM Open Source License
URL: http://epydoc.sourceforge.net
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/60/a7/666cb415b0f5d8d5c99f145e03a6005220090d7b77637871ac52c2cabcba/epydoc-3.0.1.tar.gz
BuildArch: noarch
%description
Epydoc is a tool for generating API documentation documentation for
Python modules, based on their docstrings. For an example of epydoc's
output, see the API documentation for epydoc itself (`html
`__\ , `pdf
`__\ ). A lightweight markup
language called `epytext `__
can be used to format docstrings, and to add information about
specific fields, such as parameters and instance variables. Epydoc
also understands docstrings written in `reStructuredText
`__\ , Javadoc, and
plaintext. For a more extensive example of epydoc's output, see the
API documentation for `Python 2.5
`__\ .
%package -n python3-epydoc
Summary: Edward Loper's API Documentation Generation Tool
Provides: python-epydoc
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-epydoc
Epydoc is a tool for generating API documentation documentation for
Python modules, based on their docstrings. For an example of epydoc's
output, see the API documentation for epydoc itself (`html
`__\ , `pdf
`__\ ). A lightweight markup
language called `epytext `__
can be used to format docstrings, and to add information about
specific fields, such as parameters and instance variables. Epydoc
also understands docstrings written in `reStructuredText
`__\ , Javadoc, and
plaintext. For a more extensive example of epydoc's output, see the
API documentation for `Python 2.5
`__\ .
%package help
Summary: Development documents and examples for epydoc
Provides: python3-epydoc-doc
%description help
Epydoc is a tool for generating API documentation documentation for
Python modules, based on their docstrings. For an example of epydoc's
output, see the API documentation for epydoc itself (`html
`__\ , `pdf
`__\ ). A lightweight markup
language called `epytext `__
can be used to format docstrings, and to add information about
specific fields, such as parameters and instance variables. Epydoc
also understands docstrings written in `reStructuredText
`__\ , Javadoc, and
plaintext. For a more extensive example of epydoc's output, see the
API documentation for `Python 2.5
`__\ .
%prep
%autosetup -n epydoc-3.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-epydoc -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 3.0.1-1
- Package Spec generated