%global _empty_manifest_terminate_build 0
Name:		python-atomos
Version:	0.3.1
Release:	1
Summary:	Atomic primitives for Python.
License:	BSD
URL:		https://github.com/maxcountryman/atomos
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e1/6b/a6dd2844d5c8ac324fc87bc2b68f7165062f288dc54834a09aeda2780335/atomos-0.3.1.tar.gz
BuildArch:	noarch


%description
Atomic primitives for Python.
Links
`````
* `documentation <https://atomos.readthedocs.org/en/latest/>`_
* `development version <https://github.com/maxcountryman/atomos>`_

%package -n python3-atomos
Summary:	Atomic primitives for Python.
Provides:	python-atomos
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-atomos
Atomic primitives for Python.
Links
`````
* `documentation <https://atomos.readthedocs.org/en/latest/>`_
* `development version <https://github.com/maxcountryman/atomos>`_

%package help
Summary:	Development documents and examples for atomos
Provides:	python3-atomos-doc
%description help
Atomic primitives for Python.
Links
`````
* `documentation <https://atomos.readthedocs.org/en/latest/>`_
* `development version <https://github.com/maxcountryman/atomos>`_

%prep
%autosetup -n atomos-0.3.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-atomos -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.1-1
- Package Spec generated