%global _empty_manifest_terminate_build 0
Name: python-pymedphys
Version: 0.39.3
Release: 1
Summary: Medical Physics library
License: Apache-2.0
URL: https://pymedphys.com
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4b/e5/152b9b702003721e5f36a39b186352fb214fe911c769f777c3b09abfcbf1/pymedphys-0.39.3.tar.gz
BuildArch: noarch
Requires: python3-typing-extensions
Requires: python3-tqdm
Requires: python3-attrs
Requires: python3-watchdog
Requires: python3-keyring
Requires: python3-packaging
Requires: python3-PyYAML
Requires: python3-requests
Requires: python3-dateutil
Requires: python3-matplotlib
Requires: python3-scipy
Requires: python3-xarray
Requires: python3-pymssql
Requires: python3-sqlalchemy
Requires: python3-natsort
Requires: python3-tomlkit
Requires: python3-toml
Requires: python3-pynetdicom
Requires: python3-dbfread
Requires: python3-xmltodict
Requires: python3-timeago
Requires: python3-xlsxwriter
Requires: python3-plotly
Requires: python3-fsspec
Requires: python3-dicompyler-core
Requires: python3-scikit-learn
Requires: python3-imageio
Requires: python3-streamlit
Requires: python3-streamlit-ace
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-pydicom
Requires: python3-shapely
Requires: python3-scikit-image
Requires: python3-pylibjpeg-libjpeg
Requires: python3-pylinac
Requires: python3-reportlab
Requires: python3-pywin32
Requires: python3-ipython
Requires: python3-Pillow
Requires: python3-flashgamma
Requires: python3-sphinx-argparse
Requires: python3-sphinx-book-theme
Requires: python3-jupyter-book
Requires: python3-networkx
Requires: python3-pytest
Requires: python3-pytest-sugar
Requires: python3-hypothesis
Requires: python3-astroid
Requires: python3-psutil
Requires: python3-pylint
Requires: python3-pytest-rerunfailures
Requires: python3-pre-commit
Requires: python3-black
Requires: python3-mypy
Requires: python3-rope
Requires: python3-doc8
Requires: python3-readme-renderer
Requires: python3-tabulate
Requires: python3-pyoxidizer
%description
PyMedPhys is an open-source Medical Physics python library built by an open
community that values and prioritises code sharing, review, improvement, and
learning from each other. It is inspired by the collaborative work of our
physics peers in astronomy and the `Astropy Project`_. PyMedPhys is available
on `PyPI`_ and `GitHub`_. For more information, please read the
`Statement of Need`_.
Beta level of development
*************************
PyMedPhys is currently within the ``beta`` stage of its life-cycle. It will
stay in this stage until the version number leaves ``0.x.x`` and enters
``1.x.x``. While PyMedPhys is in ``beta`` stage, **no API is guaranteed to be
stable from one release to the next.** In fact, it is very likely that the
entire API will change multiple times before a ``1.0.0`` release. In practice,
this means that upgrading ``pymedphys`` to a new version will possibly break
any code that was using the old version of pymedphys. We try to be abreast of
this by providing details of any breaking changes from one release to the next
within the `Release Notes`_.
Community
**************
PyMedPhys has a `Discourse community `_
to both help you find your feet using PyMedPhys and to facilitate collaboration
and general discussion. Please reach out over there and we'd love to get to
know you!
%package -n python3-pymedphys
Summary: Medical Physics library
Provides: python-pymedphys
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pymedphys
PyMedPhys is an open-source Medical Physics python library built by an open
community that values and prioritises code sharing, review, improvement, and
learning from each other. It is inspired by the collaborative work of our
physics peers in astronomy and the `Astropy Project`_. PyMedPhys is available
on `PyPI`_ and `GitHub`_. For more information, please read the
`Statement of Need`_.
Beta level of development
*************************
PyMedPhys is currently within the ``beta`` stage of its life-cycle. It will
stay in this stage until the version number leaves ``0.x.x`` and enters
``1.x.x``. While PyMedPhys is in ``beta`` stage, **no API is guaranteed to be
stable from one release to the next.** In fact, it is very likely that the
entire API will change multiple times before a ``1.0.0`` release. In practice,
this means that upgrading ``pymedphys`` to a new version will possibly break
any code that was using the old version of pymedphys. We try to be abreast of
this by providing details of any breaking changes from one release to the next
within the `Release Notes`_.
Community
**************
PyMedPhys has a `Discourse community `_
to both help you find your feet using PyMedPhys and to facilitate collaboration
and general discussion. Please reach out over there and we'd love to get to
know you!
%package help
Summary: Development documents and examples for pymedphys
Provides: python3-pymedphys-doc
%description help
PyMedPhys is an open-source Medical Physics python library built by an open
community that values and prioritises code sharing, review, improvement, and
learning from each other. It is inspired by the collaborative work of our
physics peers in astronomy and the `Astropy Project`_. PyMedPhys is available
on `PyPI`_ and `GitHub`_. For more information, please read the
`Statement of Need`_.
Beta level of development
*************************
PyMedPhys is currently within the ``beta`` stage of its life-cycle. It will
stay in this stage until the version number leaves ``0.x.x`` and enters
``1.x.x``. While PyMedPhys is in ``beta`` stage, **no API is guaranteed to be
stable from one release to the next.** In fact, it is very likely that the
entire API will change multiple times before a ``1.0.0`` release. In practice,
this means that upgrading ``pymedphys`` to a new version will possibly break
any code that was using the old version of pymedphys. We try to be abreast of
this by providing details of any breaking changes from one release to the next
within the `Release Notes`_.
Community
**************
PyMedPhys has a `Discourse community `_
to both help you find your feet using PyMedPhys and to facilitate collaboration
and general discussion. Please reach out over there and we'd love to get to
know you!
%prep
%autosetup -n pymedphys-0.39.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pymedphys -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.39.3-1
- Package Spec generated