%global _empty_manifest_terminate_build 0
Name: python-teedoc
Version: 1.33.3
Release: 1
Summary: doc site generator with multiple doc support
License: MIT
URL: https://github.com/Neutree/teedoc
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a6/d1/da1090e46af7d300dad0352c4655712d92d7b275bde89ad43ac0c3ec17ab/teedoc-1.33.3.tar.gz
BuildArch: noarch
Requires: python3-PyYaml
Requires: python3-babel
Requires: python3-coloredlogs
Requires: python3-flask
Requires: python3-html2text
Requires: python3-jinja2
Requires: python3-mistune
Requires: python3-nbconvert
Requires: python3-progress
Requires: python3-requests
Requires: python3-watchdog
%description
[中文](./README_ZH.md) | English
[](./LICENSE) [](https://pypi.org/project/teedoc/#history)   [](https://github.com/teedoc/teedoc/actions/workflows/test.yml) [](https://github.com/teedoc/teedoc)
Official site: [teedoc.neucrack.com](https://teedoc.neucrack.com) or [teedoc.github.io](https://teedoc.github.io/)
More demo: see [here](https://teedoc.neucrack.com/get_started/zh/usage/sites.html) or [here](https://teedoc.github.io/get_started/zh/usage/sites.html)
documentation generate tool from markdown and jupyter notebook to html

`teedoc` can be used in the following scenarios:
* Build a document website, and it is best to support multiple documents and custom pages
* Organizations' or companies' docs spread in different domains, wish to combine them to one site(domain)
* Build a `WiKi` website
* Build personal or corporate knowledge base
* Build personal or corporate website
## Features
- [x] Easy to use, cross platform, only need `Python3`
- [x] Easy to deploy, only copy generated staitc HTML files to your server or other host
- [x] Easy to write, markdown support
- [x] Jupyter notebook support
- [x] Multiple docs support
- [x] Plugin support
- [x] Multiple theme support(support by plugin)
- [x] Control the style accurate to the page through css (implemented by customizing the id and class of each page)
- [x] Multi-level directory support
- [x] Multi-language support (manual translation) (Internationalization/i18n)
- [x] Multilingual support (translation plugin)
- [x] Multiple version support
- [x] Search support
- [x] SEO friendly
- [x] Real-time preview file changes
- [x] Parallel build, faster build speed
- [x] Blog support
- [x] Jinja2 HTML layout template support
## Get Started
Visit official site: [teedoc.github.io](https://teedoc.github.io/) or [teedoc.neucrack.com](https://teedoc.neucrack.com/)
## Create your website on github pages in minutes
See [template repo](https://github.com/teedoc/template)
## Quik start
* Install python3
On `Windows` or `macOS`, download from [python.org](https://www.python.org/downloads/)
On `Linux`, `Ubuntu` for example:
```
sudo apt install python3 python3-pip
```
* Install teedoc
This command will **install teedoc program**
```
pip3 install -U teedoc
```
* Initialize document
```
mkdir my_site
cd my_site
teedoc init
```
or
```
teedoc -d my_site init
```
> select minimal template in promot
* Install plugins
This command will **install plugins** used by doc(set in `site_config.json`)
```
cd my_site
teedoc install
```
* build or serve
```
teedoc serve
```
then visit [http://127.0.0.1:2333](http://127.0.0.1:2333) in browser
If you only want to generate htmls:
```
teedoc build
```
%package -n python3-teedoc
Summary: doc site generator with multiple doc support
Provides: python-teedoc
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-teedoc
[中文](./README_ZH.md) | English
[](./LICENSE) [](https://pypi.org/project/teedoc/#history)   [](https://github.com/teedoc/teedoc/actions/workflows/test.yml) [](https://github.com/teedoc/teedoc)
Official site: [teedoc.neucrack.com](https://teedoc.neucrack.com) or [teedoc.github.io](https://teedoc.github.io/)
More demo: see [here](https://teedoc.neucrack.com/get_started/zh/usage/sites.html) or [here](https://teedoc.github.io/get_started/zh/usage/sites.html)
documentation generate tool from markdown and jupyter notebook to html

`teedoc` can be used in the following scenarios:
* Build a document website, and it is best to support multiple documents and custom pages
* Organizations' or companies' docs spread in different domains, wish to combine them to one site(domain)
* Build a `WiKi` website
* Build personal or corporate knowledge base
* Build personal or corporate website
## Features
- [x] Easy to use, cross platform, only need `Python3`
- [x] Easy to deploy, only copy generated staitc HTML files to your server or other host
- [x] Easy to write, markdown support
- [x] Jupyter notebook support
- [x] Multiple docs support
- [x] Plugin support
- [x] Multiple theme support(support by plugin)
- [x] Control the style accurate to the page through css (implemented by customizing the id and class of each page)
- [x] Multi-level directory support
- [x] Multi-language support (manual translation) (Internationalization/i18n)
- [x] Multilingual support (translation plugin)
- [x] Multiple version support
- [x] Search support
- [x] SEO friendly
- [x] Real-time preview file changes
- [x] Parallel build, faster build speed
- [x] Blog support
- [x] Jinja2 HTML layout template support
## Get Started
Visit official site: [teedoc.github.io](https://teedoc.github.io/) or [teedoc.neucrack.com](https://teedoc.neucrack.com/)
## Create your website on github pages in minutes
See [template repo](https://github.com/teedoc/template)
## Quik start
* Install python3
On `Windows` or `macOS`, download from [python.org](https://www.python.org/downloads/)
On `Linux`, `Ubuntu` for example:
```
sudo apt install python3 python3-pip
```
* Install teedoc
This command will **install teedoc program**
```
pip3 install -U teedoc
```
* Initialize document
```
mkdir my_site
cd my_site
teedoc init
```
or
```
teedoc -d my_site init
```
> select minimal template in promot
* Install plugins
This command will **install plugins** used by doc(set in `site_config.json`)
```
cd my_site
teedoc install
```
* build or serve
```
teedoc serve
```
then visit [http://127.0.0.1:2333](http://127.0.0.1:2333) in browser
If you only want to generate htmls:
```
teedoc build
```
%package help
Summary: Development documents and examples for teedoc
Provides: python3-teedoc-doc
%description help
[中文](./README_ZH.md) | English
[](./LICENSE) [](https://pypi.org/project/teedoc/#history)   [](https://github.com/teedoc/teedoc/actions/workflows/test.yml) [](https://github.com/teedoc/teedoc)
Official site: [teedoc.neucrack.com](https://teedoc.neucrack.com) or [teedoc.github.io](https://teedoc.github.io/)
More demo: see [here](https://teedoc.neucrack.com/get_started/zh/usage/sites.html) or [here](https://teedoc.github.io/get_started/zh/usage/sites.html)
documentation generate tool from markdown and jupyter notebook to html

`teedoc` can be used in the following scenarios:
* Build a document website, and it is best to support multiple documents and custom pages
* Organizations' or companies' docs spread in different domains, wish to combine them to one site(domain)
* Build a `WiKi` website
* Build personal or corporate knowledge base
* Build personal or corporate website
## Features
- [x] Easy to use, cross platform, only need `Python3`
- [x] Easy to deploy, only copy generated staitc HTML files to your server or other host
- [x] Easy to write, markdown support
- [x] Jupyter notebook support
- [x] Multiple docs support
- [x] Plugin support
- [x] Multiple theme support(support by plugin)
- [x] Control the style accurate to the page through css (implemented by customizing the id and class of each page)
- [x] Multi-level directory support
- [x] Multi-language support (manual translation) (Internationalization/i18n)
- [x] Multilingual support (translation plugin)
- [x] Multiple version support
- [x] Search support
- [x] SEO friendly
- [x] Real-time preview file changes
- [x] Parallel build, faster build speed
- [x] Blog support
- [x] Jinja2 HTML layout template support
## Get Started
Visit official site: [teedoc.github.io](https://teedoc.github.io/) or [teedoc.neucrack.com](https://teedoc.neucrack.com/)
## Create your website on github pages in minutes
See [template repo](https://github.com/teedoc/template)
## Quik start
* Install python3
On `Windows` or `macOS`, download from [python.org](https://www.python.org/downloads/)
On `Linux`, `Ubuntu` for example:
```
sudo apt install python3 python3-pip
```
* Install teedoc
This command will **install teedoc program**
```
pip3 install -U teedoc
```
* Initialize document
```
mkdir my_site
cd my_site
teedoc init
```
or
```
teedoc -d my_site init
```
> select minimal template in promot
* Install plugins
This command will **install plugins** used by doc(set in `site_config.json`)
```
cd my_site
teedoc install
```
* build or serve
```
teedoc serve
```
then visit [http://127.0.0.1:2333](http://127.0.0.1:2333) in browser
If you only want to generate htmls:
```
teedoc build
```
%prep
%autosetup -n teedoc-1.33.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-teedoc -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.33.3-1
- Package Spec generated