%global _empty_manifest_terminate_build 0
Name: python-carbonplan-styles
Version: 0.4.2
Release: 1
Summary: CarbonPlan plotting styles
License: MIT
URL: https://github.com/carbonplan/styles
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/47/97/c451aea6998468c8453419a78706b443ebf2be5d9f54581729065c7a4496/carbonplan-styles-0.4.2.tar.gz
BuildArch: noarch
Requires: python3-altair
Requires: python3-carbonplan
Requires: python3-matplotlib
Requires: python3-seaborn
%description
# carbonplan / styles
**plot styles for matplotlib and altair**
[![GitHub][github-badge]][github]
[![Build Status]][actions]
![MIT License][]
[github]: https://github.com/carbonplan/styles
[github-badge]: https://badgen.net/badge/-/github?icon=github&label
[build status]: https://github.com/carbonplan/styles/actions/workflows/main.yaml/badge.svg
[actions]: https://github.com/carbonplan/styles/actions/workflows/main.yaml
[mit license]: https://badgen.net/badge/license/MIT/blue
A collection of plotting styles for [Matplotlib](https://matplotlib.org/) and [Altair](https://altair-viz.github.io/).
Try it out on Binder:
[](https://mybinder.org/v2/gh/jhamman/carbonplan-styles/master?urlpath=lab)
## install
```shell
pip install carbonplan[styles]
```
## usage
There are currently two separate styles/themes available in this package:
1. `carbonplan_dark`: black background, lighter colors
2. `carbonplan_light`: white background, darker colors
Both styels/themes are automatically made available in Matplotlib and Altair.
### matplotlib
```python
from carbonplan import styles
styles.mpl.set_theme(style='carbonplan_dark')
```
### altair
```python
import altair as alt
alt.themes.enable('carbonplan_dark')
```
## license
All the code in this repository is [MIT](https://choosealicense.com/licenses/mit/) licensed. We include attribution for this content, and we please request that you also maintain that attribution if using this data.
## about us
CarbonPlan is a non-profit organization that uses data and science for climate action. We aim to improve the transparency and scientific integrity of carbon removal and climate solutions through open data and tools. Find out more at [carbonplan.org](https://carbonplan.org/) or get in touch by [opening an issue](https://github.com/carbonplan/styles/issues/new) or [sending us an email](mailto:hello@carbonplan.org).
%package -n python3-carbonplan-styles
Summary: CarbonPlan plotting styles
Provides: python-carbonplan-styles
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-carbonplan-styles
# carbonplan / styles
**plot styles for matplotlib and altair**
[![GitHub][github-badge]][github]
[![Build Status]][actions]
![MIT License][]
[github]: https://github.com/carbonplan/styles
[github-badge]: https://badgen.net/badge/-/github?icon=github&label
[build status]: https://github.com/carbonplan/styles/actions/workflows/main.yaml/badge.svg
[actions]: https://github.com/carbonplan/styles/actions/workflows/main.yaml
[mit license]: https://badgen.net/badge/license/MIT/blue
A collection of plotting styles for [Matplotlib](https://matplotlib.org/) and [Altair](https://altair-viz.github.io/).
Try it out on Binder:
[](https://mybinder.org/v2/gh/jhamman/carbonplan-styles/master?urlpath=lab)
## install
```shell
pip install carbonplan[styles]
```
## usage
There are currently two separate styles/themes available in this package:
1. `carbonplan_dark`: black background, lighter colors
2. `carbonplan_light`: white background, darker colors
Both styels/themes are automatically made available in Matplotlib and Altair.
### matplotlib
```python
from carbonplan import styles
styles.mpl.set_theme(style='carbonplan_dark')
```
### altair
```python
import altair as alt
alt.themes.enable('carbonplan_dark')
```
## license
All the code in this repository is [MIT](https://choosealicense.com/licenses/mit/) licensed. We include attribution for this content, and we please request that you also maintain that attribution if using this data.
## about us
CarbonPlan is a non-profit organization that uses data and science for climate action. We aim to improve the transparency and scientific integrity of carbon removal and climate solutions through open data and tools. Find out more at [carbonplan.org](https://carbonplan.org/) or get in touch by [opening an issue](https://github.com/carbonplan/styles/issues/new) or [sending us an email](mailto:hello@carbonplan.org).
%package help
Summary: Development documents and examples for carbonplan-styles
Provides: python3-carbonplan-styles-doc
%description help
# carbonplan / styles
**plot styles for matplotlib and altair**
[![GitHub][github-badge]][github]
[![Build Status]][actions]
![MIT License][]
[github]: https://github.com/carbonplan/styles
[github-badge]: https://badgen.net/badge/-/github?icon=github&label
[build status]: https://github.com/carbonplan/styles/actions/workflows/main.yaml/badge.svg
[actions]: https://github.com/carbonplan/styles/actions/workflows/main.yaml
[mit license]: https://badgen.net/badge/license/MIT/blue
A collection of plotting styles for [Matplotlib](https://matplotlib.org/) and [Altair](https://altair-viz.github.io/).
Try it out on Binder:
[](https://mybinder.org/v2/gh/jhamman/carbonplan-styles/master?urlpath=lab)
## install
```shell
pip install carbonplan[styles]
```
## usage
There are currently two separate styles/themes available in this package:
1. `carbonplan_dark`: black background, lighter colors
2. `carbonplan_light`: white background, darker colors
Both styels/themes are automatically made available in Matplotlib and Altair.
### matplotlib
```python
from carbonplan import styles
styles.mpl.set_theme(style='carbonplan_dark')
```
### altair
```python
import altair as alt
alt.themes.enable('carbonplan_dark')
```
## license
All the code in this repository is [MIT](https://choosealicense.com/licenses/mit/) licensed. We include attribution for this content, and we please request that you also maintain that attribution if using this data.
## about us
CarbonPlan is a non-profit organization that uses data and science for climate action. We aim to improve the transparency and scientific integrity of carbon removal and climate solutions through open data and tools. Find out more at [carbonplan.org](https://carbonplan.org/) or get in touch by [opening an issue](https://github.com/carbonplan/styles/issues/new) or [sending us an email](mailto:hello@carbonplan.org).
%prep
%autosetup -n carbonplan-styles-0.4.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-carbonplan-styles -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.4.2-1
- Package Spec generated