%global _empty_manifest_terminate_build 0 Name: python-django-unicorn Version: 0.50.0 Release: 1 Summary: A magical full-stack framework for Django. License: MIT URL: https://www.django-unicorn.com Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e8/0a/f9d8fc133b2bbd902dcc5413cf88bb3312f6b4e8506b673d26c5bb7edcc0/django_unicorn-0.50.0.tar.gz BuildArch: noarch Requires: python3-django Requires: python3-beautifulsoup4 Requires: python3-orjson Requires: python3-shortuuid Requires: python3-cachetools Requires: python3-dataclasses Requires: python3-decorator Requires: python3-htmlmin Requires: python3-Sphinx Requires: python3-linkify-it-py Requires: python3-myst-parser Requires: python3-furo Requires: python3-sphinx-copybutton Requires: python3-sphinx-autobuild Requires: python3-rst2pdf %description

django-unicorn logo

Unicorn

The magical full-stack framework for Django ✨

![PyPI](https://img.shields.io/pypi/v/django-unicorn?color=blue&style=flat-square) ![PyPI - Downloads](https://img.shields.io/pypi/dm/django-unicorn?color=blue&style=flat-square) ![GitHub Sponsors](https://img.shields.io/github/sponsors/adamghill?color=blue&style=flat-square) [![All Contributors](https://img.shields.io/badge/all_contributors-16-orange.svg?style=flat-square)](#contributors-) [Unicorn](https://www.django-unicorn.com) is a reactive component framework that progressively enhances a normal Django view, makes AJAX calls in the background, and dynamically updates the DOM. It seamlessly extends Django past its server-side framework roots without giving up all of its niceties or re-building your website. ## ⚑ How to use 1. [Install](https://www.django-unicorn.com/docs/installation/) `Unicorn` 1. [Create](https://www.django-unicorn.com/docs/components/) a component 1. Load the `Unicorn` templatetag with `{% load unicorn %}` and add the component to your template with `{% unicorn 'component-name' %}` 1. πŸŽ‰ ## πŸ“– More details - [Changelog](https://www.django-unicorn.com/docs/changelog/) - [Docs](https://www.django-unicorn.com/docs/) - [Screencasts](https://www.django-unicorn.com/screencasts/installation) - [Examples](https://www.django-unicorn.com/examples/todo) ## πŸ”§ To hack on the code ### Python 1. `poetry install -E minify -E docs` 1. `poetry run pytest` ### JavaScript 1. `npm install` 1. `npm run test` Check out [DEVELOPING.md](DEVELOPING.md) for more details. ## πŸ‘ Contributors Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Adam Hill
Adam Hill

πŸ’» ⚠️
Andres Vargas
Andres Vargas

πŸ’»
Eddy Ernesto del Valle Pino
Eddy Ernesto del Valle Pino

πŸ’»
Yaser Al-Najjar
Yaser Al-Najjar

πŸ’»
Stephan Traub
Stephan Traub

⚠️
Fredrik Borg
Fredrik Borg

πŸ’» ⚠️
mbacicc
mbacicc

πŸ’»
Ron
Ron

πŸ“–
Franziskhan
Franziskhan

πŸ’»
Josh Higgins
Josh Higgins

⚠️ πŸ’»
Amayas Messara
Amayas Messara

πŸ’»
Apoorva Pandey
Apoorva Pandey

⚠️ πŸ’»
Christian GonzΓ‘lez
Christian GonzΓ‘lez

πŸ’» πŸ“–
robwa
robwa

πŸ’» ⚠️
Preston Badeer
Preston Badeer

πŸ“–
Sergei
Sergei

πŸ“– πŸ’» ⚠️
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package -n python3-django-unicorn Summary: A magical full-stack framework for Django. Provides: python-django-unicorn BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-django-unicorn

django-unicorn logo

Unicorn

The magical full-stack framework for Django ✨

![PyPI](https://img.shields.io/pypi/v/django-unicorn?color=blue&style=flat-square) ![PyPI - Downloads](https://img.shields.io/pypi/dm/django-unicorn?color=blue&style=flat-square) ![GitHub Sponsors](https://img.shields.io/github/sponsors/adamghill?color=blue&style=flat-square) [![All Contributors](https://img.shields.io/badge/all_contributors-16-orange.svg?style=flat-square)](#contributors-) [Unicorn](https://www.django-unicorn.com) is a reactive component framework that progressively enhances a normal Django view, makes AJAX calls in the background, and dynamically updates the DOM. It seamlessly extends Django past its server-side framework roots without giving up all of its niceties or re-building your website. ## ⚑ How to use 1. [Install](https://www.django-unicorn.com/docs/installation/) `Unicorn` 1. [Create](https://www.django-unicorn.com/docs/components/) a component 1. Load the `Unicorn` templatetag with `{% load unicorn %}` and add the component to your template with `{% unicorn 'component-name' %}` 1. πŸŽ‰ ## πŸ“– More details - [Changelog](https://www.django-unicorn.com/docs/changelog/) - [Docs](https://www.django-unicorn.com/docs/) - [Screencasts](https://www.django-unicorn.com/screencasts/installation) - [Examples](https://www.django-unicorn.com/examples/todo) ## πŸ”§ To hack on the code ### Python 1. `poetry install -E minify -E docs` 1. `poetry run pytest` ### JavaScript 1. `npm install` 1. `npm run test` Check out [DEVELOPING.md](DEVELOPING.md) for more details. ## πŸ‘ Contributors Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Adam Hill
Adam Hill

πŸ’» ⚠️
Andres Vargas
Andres Vargas

πŸ’»
Eddy Ernesto del Valle Pino
Eddy Ernesto del Valle Pino

πŸ’»
Yaser Al-Najjar
Yaser Al-Najjar

πŸ’»
Stephan Traub
Stephan Traub

⚠️
Fredrik Borg
Fredrik Borg

πŸ’» ⚠️
mbacicc
mbacicc

πŸ’»
Ron
Ron

πŸ“–
Franziskhan
Franziskhan

πŸ’»
Josh Higgins
Josh Higgins

⚠️ πŸ’»
Amayas Messara
Amayas Messara

πŸ’»
Apoorva Pandey
Apoorva Pandey

⚠️ πŸ’»
Christian GonzΓ‘lez
Christian GonzΓ‘lez

πŸ’» πŸ“–
robwa
robwa

πŸ’» ⚠️
Preston Badeer
Preston Badeer

πŸ“–
Sergei
Sergei

πŸ“– πŸ’» ⚠️
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %package help Summary: Development documents and examples for django-unicorn Provides: python3-django-unicorn-doc %description help

django-unicorn logo

Unicorn

The magical full-stack framework for Django ✨

![PyPI](https://img.shields.io/pypi/v/django-unicorn?color=blue&style=flat-square) ![PyPI - Downloads](https://img.shields.io/pypi/dm/django-unicorn?color=blue&style=flat-square) ![GitHub Sponsors](https://img.shields.io/github/sponsors/adamghill?color=blue&style=flat-square) [![All Contributors](https://img.shields.io/badge/all_contributors-16-orange.svg?style=flat-square)](#contributors-) [Unicorn](https://www.django-unicorn.com) is a reactive component framework that progressively enhances a normal Django view, makes AJAX calls in the background, and dynamically updates the DOM. It seamlessly extends Django past its server-side framework roots without giving up all of its niceties or re-building your website. ## ⚑ How to use 1. [Install](https://www.django-unicorn.com/docs/installation/) `Unicorn` 1. [Create](https://www.django-unicorn.com/docs/components/) a component 1. Load the `Unicorn` templatetag with `{% load unicorn %}` and add the component to your template with `{% unicorn 'component-name' %}` 1. πŸŽ‰ ## πŸ“– More details - [Changelog](https://www.django-unicorn.com/docs/changelog/) - [Docs](https://www.django-unicorn.com/docs/) - [Screencasts](https://www.django-unicorn.com/screencasts/installation) - [Examples](https://www.django-unicorn.com/examples/todo) ## πŸ”§ To hack on the code ### Python 1. `poetry install -E minify -E docs` 1. `poetry run pytest` ### JavaScript 1. `npm install` 1. `npm run test` Check out [DEVELOPING.md](DEVELOPING.md) for more details. ## πŸ‘ Contributors Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Adam Hill
Adam Hill

πŸ’» ⚠️
Andres Vargas
Andres Vargas

πŸ’»
Eddy Ernesto del Valle Pino
Eddy Ernesto del Valle Pino

πŸ’»
Yaser Al-Najjar
Yaser Al-Najjar

πŸ’»
Stephan Traub
Stephan Traub

⚠️
Fredrik Borg
Fredrik Borg

πŸ’» ⚠️
mbacicc
mbacicc

πŸ’»
Ron
Ron

πŸ“–
Franziskhan
Franziskhan

πŸ’»
Josh Higgins
Josh Higgins

⚠️ πŸ’»
Amayas Messara
Amayas Messara

πŸ’»
Apoorva Pandey
Apoorva Pandey

⚠️ πŸ’»
Christian GonzΓ‘lez
Christian GonzΓ‘lez

πŸ’» πŸ“–
robwa
robwa

πŸ’» ⚠️
Preston Badeer
Preston Badeer

πŸ“–
Sergei
Sergei

πŸ“– πŸ’» ⚠️
This project follows the [all-contributors](https://github.com/all-contributors/all-contributors) specification. Contributions of any kind welcome! %prep %autosetup -n django-unicorn-0.50.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-django-unicorn -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri May 05 2023 Python_Bot - 0.50.0-1 - Package Spec generated